KDE 6 widgets fail to update

This has been a bit of a issue since kde 6 came out Widgets fail to update you have to go an manually remove them to update them the same thing with icon packs. Though they don’t give a error they just don’t react at all.

I dont actually use this one but its a example

Operating System: Garuda Linux 
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.8.7-1-cachyos (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 15.5 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 980/PCIe/SSE2

I don’t know if manually downloaded widgets use to be automatically updated. – Even if they are, remember that:

The content available here has been uploaded by users like you, and has not been reviewed by your distributor for functionality or stability.

Many of them received no maintenance by their creators, for years. – E.g. “Weather Widget” has had no changes for the last 7 years, since October 2017 – and since KDE Plasma 5.26 landed here, October 2022, it did no more work as before. – So, I had to remove it and replace it with “weather-widget-2”, a fork created by another user.

This fork does not work with Plasma 6 – so, I had to remove it and search for a new widget, specificly created for Plasma 6. – There are 6 widgets for Plasma 6 (all new), while there are 12 widgets for Plasma 5:

These are all currently updated widgets. When kde 6 hit I purged all my theming add-ons and widgets to start fresh. This issue is only with kde 6 and the new widgets. I keep track on there github/pling if they have updated ones for older ones I liked.
The issue is with the update button not actually being able to update them when it is used via kde 6 in 5 this was not a issue unless like you said it had not been maintained in years.

This issue is also the case in discover though being arch an packaget being quite risky for the system I’ve only tried it a few times but yeah even with all optional dependencies met it wont update them either. I read it was addressed in 6.0.3 but I had no luck with it.

1 Like