KDE always wants to print A4

Hi. I’m running KDE Neon, current as of today. I’ve noticed for the last 6 months or so that (suddenly) everything I print from qt/kde apps wants to print in A4 instead of US Letter. The printer is set to use letter, the document is set to use letter, everything is set to letter, but every time, it goes to A4. This causes the printer to lockup, and no one can print it it until someone goes to the printer and cancels it (which most people do not know how to do), so it is causing a lot of problems.

This is not a big problem in firefox or libreoffice, but kwrite and okular (for example) do this. I click “print” (or hit ctl+p) and the print dialog comes up. I have to go to properties (every time) and switch from A4 to letter.

I’ve seen other people have this issue when searching around the Internet… but no one ever seems to have a solution.

The odd thing is, this does not happen on my home PC… only my work PC… and they are both KDE neon, and I cannot see what the difference is.

Anyone know what is going on here?

Thanks.

Check that the tabs/guides in the paper drawer have not gotten moved. I have run into this one a lot at work.

I appreciate the input, but that is not the problem. They are snug, and I think that it would affect everything including libre and firefox if that were the issue, but it doesn’t. They print in letter size, as they should…

KDE printer setting fails (but sometimes magically succeeds) to set printer’ defaults

You can do it via CUPS web interface:

  1. Open your browser and type http://localhost:631/printers/

  2. Click on the printer you want to modify

  3. Select “Set Default Options” in second combobox

  4. Select your preferred page size and apply it

I tested system-config-printer, and changed page size then clicked on apply, it showed root password dialog, and after entering it, it seems to always work. While KDE printer settings doesn’t trigger any root password dialog.

I think there is a permission problem with KDE printer settings…

See if the kio_admin package is installed. I learned of this the other day in a thread discussing running dolphin as root. That gives you a dialog to authenticate opening a root owned folder as root user perhaps it may do the same for the printer dialog. Though you better know the password as clicking on cancel or entering an invalid password is useless for getting rid of the dialog only the correct password and clicking ok will dismiss it anything else and it stay right there. For as many times as you want to click cancel I only went to five or so before entering in the password to get rid of the damn uselessly designed thing, if cancel does not cancel the button should not be there to select.