KDE Connect does not work correctly on KDE Neon


I’ve issues with KDE connect on my Neon PC (KDE neon 5.27 and KDE Connect 23.08.4). My phone on the same network does not show up. I’ve an other PC with Kubuntu (20.04.6 and KDE Connect 1.4-0ubuntu5) on the same network and the my phone shows up in KDE Connect but not my Neon PC. Most interesting: the Kubuntu PC is visible in KDE Connect on the Neon PC!

When I do “the usual stuff” on my Neon PC I get:

$ netcat -z -v 1714-1764
netcat: connect to port 1714 (tcp) failed: Connection refused
netcat: connect to port 1715 (tcp) failed: Connection refused
Connection to 1716 port [tcp/*] succeeded!

where is the IP of my phone. The firewall on my Neon PC is completely disabled. Doing:

killall kdeconnectd
mv ~/.config/kdeconnect ~/.config/kdeconnect.bak

does not help. I also can see the mDNS broadcasts of my phone when I do a refresh with KDE Connect on my phone:

$ sudo tcpdump -i eno1 -n host
tcpdump: verbose output suppressed, use -v[v]... for full protocol decode
listening on eno1, link-type EN10MB (Ethernet), snapshot length 262144 bytes
21:33:41.764845 IP > 0 [1a] PTR (QM)? _kdeconnect._udp.local. (71)
21:33:42.765719 IP > 0 [1a] PTR (QM)? _kdeconnect._udp.local. (71)
21:33:43.095745 IP > 0 [1a] PTR (QM)? _kdeconnect._udp.local. (71)
21:33:44.194268 IP > 0 [1a] PTR (QM)? _kdeconnect._udp.local. (71)
21:33:45.100956 IP > 0 [1a] PTR (QM)? _kdeconnect._udp.local. (71)

IMHO everything works as expected just KDE Connect on my Neon PC does not.

Any suggestions how to fix this?


I don’t use KDE Connect, because I found it did very little with my iPhone. However, when I tried to get it working, I had to open certain ports in my firewall.

Hi, how’s and going? do you trying using the explanation with the link below : KDEConnect - KDE UserBase Wiki

As stated in my post I did “the usual stuff”: any thing that could be found here:


The results could be found in my initial post. No success …

I’ve personally had similar issues with KDE connect on 5.27.x on Fedora.
I followed the trouble shouting steps a few times to figure out what is wrong, they do show, there can be data sent between my phone and computer, but they won’t connect, which I couldn’t figure out fully, why that is the case?

I suspect it’s because I use vpn on both devices. Even with local network discovery enabled on both, kde connect does not work.

I’m waiting on Plasma 6 to drop to see if it’s still an issue.

I also think that there is a problem with the current release on plasma 5. With KDE Connect 1.4 the problem does not exist for me.

Do you trying to ping using your mobile to your device? and your mobile how version is, android or iphone?

Ping works in both directions. As you can see in my initial post even broadcasts are visible, ports are open and reachable. Android … of course :slight_smile:

As said: with KDE Connect 1.4 the problem does not exist for me.

Okay, good luck solving this problem. youre gonna need it!

Solved, in an unexpected way. Lately I received a Galaxy S24 Ultra. With this phone every thing works as expected. With the OnePlus 8 pro it does not.

The problem is back after I’ve activated a work profile on the phone. All devices can connect to each other with KDE connect but my Plasma 5 setup.

Update: tried fresh Neon download in Virtualbox. Current stable does not wok but testing does.

I had to go dig it out of my rss feed but this blog post might explain why kde connect is often unreliable.

Discovery is possible in the current protocol using UDP broadcasts, but the state of the art nowadays is to use multicast DNS (mDNS) instead, which is more reliable and less often blocked by the network configuration. We wanted (and tried) to adopt mDNS for a while, but it was a a bigger endeavour than what we could tackle.

Thanks, but all systems are on the same broadcast domain / network segment. When you have a look at my initial post you will see that the UDP broadcast packets arrive at my client. The UDP broadcasts are not the problem. The problem is some where in the current stable Neon release. See my latest post, with “testing” it works.

BTW: entering the IP of my desktop on Android has no effect.

When will Plasma 6 make it to “stable”?

If it’s not UDP broadcast, I am at lost to what the issue is?
If it works in testing, maybe plasma 6 will have it working without any problems?


28th of this month, Other than Arch, Most distro’s won’t have Plasma 6 until their April release cycle.

What about Neon ? I got it working with RC1.

Neon is a weird one, All plasma packages should update to most stable version once available, that’s assuming you’re on the stable version of neon, not the testing branch.

Latest news for my system with Plasma 5: after a reboot (I don’t do this very often …) it now works again with my S24 !

1 Like