KDE Connect File System Expose is not working (on KDE Neon)

I get this issue:

Yes, I have openssh and sftp installed.

If I spin up a virtual machine with a Fedora KDE spin, KDE Connect works perfectly. So, what is specific to KDE Neon that is causing this issue?

Okay… After some digging, I think I get it. It won’t work because sshfs on 22.04 is so old (version 3.7.1). Meanwhile, on Fedora, it’s 3.7.3

So, until KDE Neon can be upgraded to 24.04 (which has the 3.7.3 version), people who use KDE Neon and who try to use File System expose feature are screwed.

Syncthing, or plugging in the phone via USB is the only option.

Does the 22.04 upgrade released yet?
And when it’s released should we reinstall KDE Neon from the ISO in the website or just usual upgrade in Discover?:thinking:

Even a fresh installation of KDE Neon won’t change this. It still uses Ubuntu 22.04 as its base.

And when we go to upgrade to 24.04, there will be a tray notification that opens an application for upgrading; separate from Discover.

So we upgrade to 22.04 without reinstalling from ISO?:thinking:
By some notification in tray icon instead of the dicover?

That’s what I said. I’ve done it 3 times so far since I installed KDE Neon when it was using 18.04 as the Ubuntu base.

Advice; backup the system before you do it. Because before when I was using 16.04, and then tried upgrading to 18.04, it broke my system. So, backup before doing the upgrade as a fail safe.

I honestly, make a backup. Then I restore it into a virtual disk and attempt to upgrade as a test in the virtual machine. And if it goes well, I upgrade my actual system.

1 Like

Sure will follow this​:fire::ok_hand:. Thanks

I don’t think sshfs 3.7.3 will fix this as I’m having the same issues in Kubuntu 22.04 with an Android 14 device - it will connect fine with Android 11 - and have just compiled sshfs 3.7.3 from github and it still isn’t working.

Well, Fedora with that version of sshfs worked.

EDIT:

I also tried Kubuntu 24.04 in a virtual machine with a bridged network connection. And the file system expose works with sshfs 3.7.3

I also see something interesting. Seems like fuse and all that other jazz is newer too on Kubuntu 24.04 as well:

SSHFS version 3.7.3
FUSE library version 3.14.0
using FUSE kernel interface version 7.31
fusermount3 version: 3.14.0

VS KDE Neon:

SSHFS version 3.7.1
FUSE library version 3.10.5
using FUSE kernel interface version 7.31
fusermount3 version: 3.10.5

So maybe fuse is the underlying issue.

I’ve gone back to KDE Connect 1.30.1 on my phone and it works again. So wondering if something changed between 1.30 and 1.31 which is what I was using that could cause this.

Well, I have 1.30.1 installed. It doesn’t work for me. :thinking: