KDE Connect on Android won't allow "Device & app notifications" permission

So I got KDE Connect between my laptop (KDE NEON) and my phone (Android 13, LineageOS), and I’m trying to get my phone notifications & media control on my laptop to my phone. In the “Device & app notifications” permission, everything is greyed out, even the Allow flag. When I click it, it says “Restricted setting. For your security, this setting is currently unavailable.” I installed KDE Connect . via F-Droid

You can change the resitriction settings per app.

Go to Apps > KDE Connect > press the three dots in the upper right corner and allow restricted settings

1 Like

I don’t have anything that says allow restricted settings. This is latest (just checked) install on Android from F-Droid, v1.26.1 from the app About section.

See the part under “Some Plugins need permission” just tap on one (like notification sync) and it will take you to the area in your settings to give that permission. Once you go back to that page in KDEConnect, you will notice it is gone from the list. I had to tap and allow each of those on my Android phone & Kindle Fire tablet when setting them up with my Kubuntu desktop.

1 Like

This is probably the solution, please mark it as that

Been there, doesn’t work. The toggle on this isn’t showing as active, and see the 2nd screenshot when I hit it to try and turn it on.

Unless it’s something specific to LineageOS, I’m at a complete loss as to what it might be.

And here’s the next screenshot, it doesn’t want me to post more than 1 per post so far.

Settings → apps → kde connect → three dots at the top right

Then the dialog works

Ah, you’re referring to Android Settings, not from KDE Connect app. Wasn’t made clear to me before.