KDE Connect remote input feature for android not working


I have a rather specific problem since I am almost fully paralysed because of a neuro-muscular disease.
Because of this, I’m not able to use a touchscreen. So I’d like to use the remote input feature of KDE Connect in order to be able to control my android phone from my windows 11 pc or android tablet using a mouse. This avoids having to switch devices by inserting a mouse elsewhere all the time, which I can’t do by myself. There are other software tools like Teamviewer with which I can control my phone from my pc, but they work by copying the screen and as a consequence certain apps (like for identification or banking) don’t work with it for security reasons.

As KDE Connect normally allows control by projecting a mouse only, without copying the screen, I hoped this would solve my problem (as I have my phone in viewing distance).

Regretfully I can’t get this feature to work on my Oneplus 7T with a modified version of Android 12 (OxygenOS 12.1)
I tried following the video in the support wiki about this:

But I just don’t get the option to enable the mouse receiver plugin on my phone as it does in the video.
It isn’t even in the list of possible plugins that need permission, nor is KDE Connect in the list of possible accessibility apps when I go to the settings of my smartphone myself.
So even though all is installed and paired correctly, remote input just doesn’t work.

Can this be solved? How?
And if not, does it work if I perhaps buy another phone? Which ones?

I just really need any sort of solution for this personal problem asap, so I’d be grateful for any kind of help or advice on this! I’m glad with any solution at this point, even if it means that I’d have to buy a new smartphone or other hardware in order to control a bluetooth mouse or something on my phone from my pc. But I’m no computer expert at all and didn’t find a solution yet.