KDE Connect stopped working for me

Hi!

I installed KDE Connect yesterday. Used it last night with no problems. Today I set it up the same way and do all the same things. Thought I’d share a bigger batch of files from my iPhone to my PC. At first it was slow and kept stalling. I cancelled the transfer, closed the app (on my phone) and program (on my PC) and went to eat some food. Came back and tried again. This time, it won’t initiate a file transfer at all. Not even for a single file. If I click on one to send, the app makes this error-type beeping sound and does nothing. I tried shutting down the programs and restarting them. No dice. It just won’t send files anymore.

Any ideas why this is happening or what I can try?

There is the ping feature in kdeconnect, does that work to indicate you even have network traffic or connecting at all during the times showing problems?

I’d check your wifi isn’t being spotty or not connecting at all. If nothing else, restart kdeconnectd (killall -9 kdeconnectd && /usr/lib/kdeconnectd 2>&1 &) and see if it just got hung up.

Check also journalctl -f logs to see if anything interesting there.

Hey! Thanks for the response. Today it’s working fine again, so I’m guessing I just needed to reboot my computer. If it acts up again, I’ll try your suggestions.

Update: this is still a significant issue for me. KDE Connect constantly fails while attempting to send files. Right now I sent a handful of files and it’s been stuck at 99% for about 10 minutes and just can’t seem to send that last 0.8MB. But the main issue is that it keeps losing the connection between my phone and PC. Often when that happens, I have to reboot my phone to make KDE Connect work again. Every day I manage, through great effort and frustration, to send a few files. At this rate, it will take months to send the 4GB of files I need copied off my phone. I’m grateful that KDE Connect exists as a tool, otherwise I would have no way of backing up my music at all, but there’s got to be a way to make it work better for me.

I am indeed able to ping, when the devices are connected.

journalctl -f revealed nothing that I found interesting, but I know very little about modern computers.

My spotty wifi may be an issue. I am trying to get that diagnosed on the Ubuntu forums.