KDE Localization: Using Western Arabic Numerals

I live in Syria, and I love KDE.

However, one thing is bugging me, While I use American English for UI language, the other regional options (Time, Date, Currency…etc) are set for Arabic Syria (ar_SY.UTF-8) except for the numbers, I don’t like using eastern Arabic numerals (٠١٢٣٤٥٦٧٨٩) which I use Western Arabic numerals (0123456789) for it, for that I select numbers locale as en_US.UTF-8.

This causes inconsistencies in the UI, as some parts uses WAN and others use EAN.

In KDE 5, it was limited to Date and Time formats, but in KDE 6 it has no logic.
What is a possible fix for this situation?

My settings

How time and date are shown in the clock


Locale command output

My neofetch output

1 Like

I fixed this behavior by editing my ~/.i18n file

Although in my case I use pt_BR instead, but I wanted numbers to use a point as a decimal separator (like in en_US), instead of a comma (like in pt_BR)

If you don’t have this file, you can create it. Mind it starts with a dot.

# ~/.i18n
export LANG=en_US.UTF-8
export LANGUAGE=en_US:en
export LC_CTYPE=en_US.UTF-8
export LC_TIME=ar_SY.UTF-8
export LC_MONETARY=ar_SY.UTF-8
export LC_MESSAGES=en_US.UTF-8
export LC_PAPER=ar_SY.UTF-8
export LC_NAME=ar_SY.UTF-8
export LC_ADDRESS=ar_SY.UTF-8
export LC_RESPONSE=en_US.UTF-8
export LC_ALL=

Some notes:

  • This file is in your user home folder, so you don’t need root permissions to edit it
  • By the same reason as above, it will only set these variables for the current user
  • I use a X11 session, I believe it should work fine for Wayland sessions, but I am not 100% sure