KDE Mouse settings

Hello,
I am using Fedora 39 KDE and in my present KDE setup I only see the following settings for the mouse:
Screenshot_20231220_164250

I remember from previous setups that there were more settings, including one for setting the accuracy for being able to click (on a button for example). I noticed now I have to keep the mouse perfectly still to make the mouse-click work, something I did not have to do before in Fedora 38, in openSUSE Tumbleweed.
This makes working with the mouse more difficult than it has to be.

Has something changed in the settings, do I need to install something to get the other settings again, or what happened? Who can help me?

click on the desktop, type “accessibility” and go to the setting page from the search result.

there are a number of settings to play with in there.

Thank you for your help, but I don’t think this is what I am looking for.
I only see items which need an amount of time. What I need is a distance in which the mouse-click is still valid. Now I click on, let’s see the close window button, but because I move the mouse at the same time the click doesn’t do what I want it to do: close the window.

I don’t know if this could be relevant: do you use Wayland or X11 ?
The options in System Settings should be the same, but the mouse input mechanics could work differently, couldn’t they?

The settings you’re missing are specific to the Evdev mouse driver. You’re not seeing them because your system is instead using the Libinput mouse driver.

If you’re on X11, this is under your control; you can choose which driver to use via your package manager or config files.

If you’re on Wayland, the Libinput driver is your only option at the moment, because the Evdev driver is unmaintained and has not been ported to work on Wayland.

If you’re having trouble with the Libinput driver, I’d recommend submitting a bug report about it instead of switching to another driver immediately. This is how stuff gets fixed in the FOSS world. :slight_smile:

This question has come up countless times. I wonder whether System Settings could make the user aware somehow of which library it’s exposing.

i was gonna ask, because there doesn’t seem to be any GUI way of choosing the mouse driver… like you can for say the GPU or like how you can change window managers.

Hello all, I started an investigation after I read Nathan’s post. I found this:
In the folder

/usr/share/X11/xorg.conf.d
$ ls
total 32K
-rw-r--r--. 1 root root  126 Feb 22  2023 10-amdgpu.conf
-rw-r--r--. 1 root root 1,1K May 29  2018 10-evdev.conf
-rw-r--r--. 1 root root 1,7K Dec 13 01:00 10-quirks.conf
-rw-r--r--. 1 root root   92 Oct 15  2019 10-radeon.conf
-rw-r--r--. 1 root root 1,4K Aug 25 02:00 40-libinput.conf
-rw-r--r--. 1 root root 3,4K Dec  6  2022 70-wacom.conf
-rw-r--r--. 1 root root  198 Aug 25 02:00 71-libinput-overrides-wacom.conf
-rw-r--r--. 1 root root  333 Nov 22 01:00 nvidia.conf

It turns out I have the evdev driver as well as the libinput one. Without uninstalling the libinput driver, how can I switch to the evdev driver? Isn’t it so that because the evdev driver has a lower number (10) it is selected above the libinput one with number 40? I do use X11 since the combination Nvidia and Wayland is still a pain in the butt.

I think its the exact opposite: Xorg - ArchWiki

With Fedora 40 dropping Xorg: F40 Change Proposal: KDE Plasma 6 (System Wide) - Fedora Discussion
you should probably request any missing feature for Libinput before its to late.

I have now renamed file 10-evdev.conf into 50-evdev.conf and in System settings I now see other parameters which I can adjust. I will experiment with these a while, but so far already it looks good.
Thank you all for helping me. Happy Holidays.

1 Like

for completeness, can you please share the final screen shot of the new mouse controls?

Here they are:
Screenshot_20231222_201631
Screenshot_20231222_201619
Screenshot_20231222_201542
Still experimenting with the settings but it’s starting to look good.

1 Like