KDE Multi-montor setup + Disabling KScreen

Thank you for viewing!

As you may know, on X11, KDE does not have a solution that will let a person scale monitors individually. They have a global scale option. The problem is that I have three monitors. The monitors from left to right have the following resolutions:


I require the one in the middle to be at 150% scaling. The problem is that the leftmost monitor (1650x1050) becomes unusable after that.

One method that i have found is to use nvidia-settings to setup a custom xorg.conf files by setting up the viewPortIn values to 2307x1440 for the left and right monitors. The problem is, KDE doesn’t read these values.

One way of making the KDE read values is by disabling KScreen in background services. The problem is that KDE doesn’t support gaps in monitors, so I was wondering if there is a solution that KDE Plasma provides that would help me setup this custom resolution without breaking the system or cause instability.

The Wayland session supports this, maybe try that first instead of working around KScreen?

Thank you. Wayland doesn’t work well with the Unity Engine, and is extremely useable when using Godot.

The Jetbrains IDE’s also appear blurry, and that hurts my eyes. Other than that, I have no problem, whatsoever. Also, there is a flickering issue with most X11 apps.

I use Nvidia.

Please note, in game dev, the flickering issues are a huge problem. This is because the ‘inspector’ of engines sometimes does not get updated. It causes major problems, most of the time.

That’s unfortunate, I’m guessing that’s related to the NVIDIA card because here on AMD I don’t have flickering with Godot :confused:

I think it is related to NVidia. It is probably an API issue as the drivers are not open source.

Is disabling K-Screen going to be a problem in the future? I know that KDE removed the ‘Power Management’ background service from the background service region.

Is there a way to edit K-Screen so that it lets xorg.conf set the monitors?

I also use differently scaled VDUs with nvidia+X11. I disable kscreen and use xrandr to do the scaling at the start of the session as part of the xinitrc processing.

I’ve created /etc/X11/xinit/xinitrc.d/50-xrandr.sh which contains:

xrandr --output DP-4 --auto --output DP-0 --auto --scale 1.75x1.75 --right-of DP-4

The same command can be run after login as well, but I prefer it to be automatically run at startup.

I’ve been doing the above for years. but I suppose the day may come where such an unsupported configuration may break, but hopefully it may last until Wayland becomes solid enough for me to switch.

I think the arch wiki lead me to this solution: HiDPI - ArchWiki

Thank you for the reply. I am currently using nvidia-settings to create an xorg.conf file. The problem is, it is unsupported. So whenever I do this, my anxiety levels go high.

I am concerned as Plasma might decide to go the same route as Gnome. I have been searching for over a month on how to disable the K-screen equivalent on Cinnamon (which uses Gnome components). You won’t how I was treated on the official Linux Mint forums about this. Just mentioning KDE plasma probably triggered them.