KDE Neon cannot be installed wine winehq-stable

Hi, it’s my first time here and I don’t know if this is really going here but I’ve been trying to install wine stable for several weeks but I can’t because I get the error:

Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) winehq-stable:amd64 < none -> 8.0.2~jammy-1 @un puN Ib >
Broken winehq-stable:amd64 Depends on wine-stable:amd64 < none @un H > (= 8.0.2~jammy-1)
  Considering wine-stable:amd64 0 as a solution to winehq-stable:amd64 9999
  Considering wine-stable:i386 0 as a solution to winehq-stable:amd64 9999
Done
Some packages could not be installed. This may mean that
you asked for an impossible situation or, if you are using unstable distribution, that some necessary packages
unstable distribution, that some necessary packages have not yet been created or have been taken from
have been taken out of "Incoming".
The following information may help resolve the situation:

The following packages have unfulfilled dependencies:
 winehq-stable : Depends: wine-stable (= 8.0.2~jammy-1).
E: Could not fix the problems, you have retained broken packages.

I have already installed wine version 6.0.3 from the ubuntu repos through apt but I want to install the stable version which is version 8.

My distro info:

KDE Neon 5.27
KDE plasma: 5.27.10
Release: 22.04
kernel 6.2.0-39
Protocol: Wayland

Have you read all of WinHQ’s page for Ubuntu?

It provides instruction for neon.

Terminal commands:

sudo dpkg --add-architecture i386
sudo mkdir -pm755 /etc/apt/keyrings
sudo wget -O /etc/apt/keyrings/winehq-archive.key https://dl.winehq.org/wine-builds/winehq.key
sudo wget -NP /etc/apt/sources.list.d/ https://dl.winehq.org/wine-builds/ubuntu/dists/jammy/winehq-jammy.sources
sudo apt update
sudo apt install libpoppler-glib8:{i386,amd64}=22.02.0-2ubuntu0.3 -y
sudo apt install --install-recommends winehq-stable -y
wine winecfg

Test …
wine clock

Test the Internet connection with Internet Explorer
wine iexplore

install wine-mono and Gecko packages, when prompted …

Some programs need the winbind package for the Internet connection.

sorry for the late reply, thank you very much for your answer, it worked for me! surely I missed a step in the libpoppler-glib8 dependency.