KDE Neon downgraded back to X11 after a system update?

Not really an issue per se but something odd I discovered is that my KDE Neon installation went from Wayland to X11 over the course of an update.
A bit of a story:
I’ve been using KDE Neon for a couple of months now and it’s failed to boot properly for me twice in that time: like the boot, or at least the graphical desktop environment, is completely broken. The first time was on 2024-03-15: I could get into the detached TTY by hitting Ctrl+Alt+F4 and in this shell I tried fix things to no avail; I suspect the system was mid transition to a new Linux kernel when things went wrong, so ultimately I just did a fresh install with the latest ISO released. While this was a painful inconvenience, when I had the newer version running I noticed it was now using Wayland as the display/window manager rather than X11, which I thought was really cool; a bit of a workflow adjustment, had to go from using xclip to wl-clipboard but I was happy to finally be using a distro with Wayland: plus, in my mind, it more-so justified the previous boot failure, assuming it could’ve been caught mid update moving from X11 to Wayland. Then two days ago, my system randomly failed to boot again; it was different this time as I could move a mouse cursor but it was just on a black screen. Using Grub, I ran pkcon in a root shell which seemed to fix things: afterwards, I could boot normally again but came to discover wl-clipboard no longer worked. When I checked the Info Center, I saw this:

Operating System: KDE neon 6.0
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.5.0-28-generic (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-7700HQ CPU @ 2.80GHz
Memory: 15.4 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 630
Manufacturer: Dell Inc.
Product Name: Inspiron 7577

Yeah, somehow my system has reverted to X11. What’s going on?

Select the wayland session in SDDM (the login screen).