kde neon immediately wakes up after suspend

neon immediately wakes up after suspend


When I request a suspend, kde neon does it but right away, 1-2 seconds, it wakes up again.
This started happening since the 24th Nov 2023. One night it works the next it didn’t.

To quick test/debug peripherals:
I’ve run “sleep 30 ; sudo pm-suspend”
during the “sleep 30” I unplug mouse, keyboard and lan cable.
It goes to suspend but wakes up.


To eliminate the case of installed programs/drivers, I’ve live booted with a kde neon from january 2023 that should work and suspend it.
Problem persist. Wakes up right away.


Live booted with a debian 11 iso and suspend it.
It works. Stays suspended.
Version of pm-utils is the same 1.4.1-19 in live-debian as is installed kde neon.

“systemctl suspend” never worked correctly, it freezes the computer with keyboard and monitor off. So I’ve used pm-suspend.


Just one thing to check.

If you have Steam running in the background, it has to be shut down.

You’re mentioning pm-suspend. Does it also happen if you request suspend with the methods Plasma provides, e.g. by typing “sleep” in the application launcher or configuring your power button to trigger sleep in energy saving settings?

The sleep button on plasma has the same effect as “systemctl suspend”… it freezes my computer, that is the reason why I use pm-suspend. Maybe it’s because I have a nvidia card, I recall something about it, looks like it still not fixed.

I’ve tried the live-usb neon iso (version 23-nov.-2023 and january 2023) and the sleep button on plasma, just as the pm-suspend on my real machine, goes into suspend and wakes up immediately.

rest of the config:
cpu: amd ryzen 9 7900x
motherboard: gigabyte x670e aorus master, latest bios f20a that has agesa
ram: 128GB
gpu: asus nvidia gtx 980

If the freeze after systemctl suspend happens after suspend check if the nvidia-resume systemd service enabled.

Run systemctl status nvidia-resume.service if it says disabled enable it (run systemctl enable nvidia-resume.service), reboot and try again normal suspend to see if it changes anything.

status of nvidia-resume.service is “Active: inactive (dead)”.

Done the enabling, rebooted, doesn’t seem to stay active.

So did a disable of it. Then redo the enabling, result:
Created symlink /etc/systemd/system/systemd-suspend.service.wants/nvidia-resume.service → /lib/systemd/system/nvidia-resume.service.
Created symlink /etc/systemd/system/systemd-hibernate.service.wants/nvidia-resume.service → /lib/systemd/system/nvidia-resume.service.

then start it, and status gives:
nvidia-resume.service - NVIDIA system resume actions
Loaded: loaded (/lib/systemd/system/nvidia-resume.service; enabled; vendor preset: enabled)
Active: inactive (dead)
systemd[1]: Starting NVIDIA system resume actions…
suspend[11813]: nvidia-resume.service
logger[11813]: <13>Nov 28 23:00:26 suspend: nvidia-resume.service
systemd[1]: nvidia-resume.service: Deactivated successfully.
systemd[1]: Finished NVIDIA system resume actions.

This time before rebooting tried “systemctl suspend” and same as my original question with pm-suspend… pc suspends and wakes up immediately.

But is the freeze fixed?

Have you tried this for the wake up? Power management/Wakeup triggers - ArchWiki

Sorry for the delay, but the nvidia card decided to break. So had to buy a new card, this time an Amd rx7900xtx.

Prior to the change of card, after enabling the service and start it, “systemctl suspend” did NOT freeze pc.

Then and now, with new card, “systemctl suspend” and “pm-suspend” do the same problem…pc wakes up right away.

I just went through the link (thank you) , but it did NOT help. In my case, the entries in /proc/acpi/wakeup are all labeled as S4, and 27 (19 if remove duplicates) of then are listed as enable. I went through all of 19 listed as enabled , one by one, (yes… 19 suspend and wake up in a row :frowning: ) It did NOT work.

If you no longer have a Nvidia gpu in the system I would recommend to uninstall the driver and other nvidia related packages. Or at least disable any service related to it like nvidia-resume.service as you no longer need them.

Then please do this:

  1. Reboot
  2. After booting try to suspend
  3. After it wakes open a terminal and run sudo dmesg -HT > log.txt upload the file to google drive, github gist or any paste service of your preference (I don’t know what’s the consensus/preference for file uploads here :slight_smile: ) and share the link here
1 Like

Outputs of lsusb and lspci -nnD might be useful too.

hello, did all that , files (lsusb.txt, lspci.txt and lsdmesg.txt ) at : https://file.io/uQQleklumnYD Aparrently will be deleted the 16 december 2023.

Looking at the dmesg there is an error in the amdgpu kernel module that happens when suspending:

[sáb dic  2 22:33:21 2023] PM: suspend entry (deep)
[sáb dic  2 22:33:22 2023] ------------[ cut here ]------------
[sáb dic  2 22:33:22 2023] WARNING: CPU: 18 PID: 3962 at drivers/gpu/drm/amd/amdgpu/amdgpu_irq.c:600 amdgpu_irq_put+0xa4/0xc0 [amdgpu]
[sáb dic  2 22:33:22 2023] Modules linked in: xt_CHECKSUM xt_MASQUERADE xt_conntrack ipt_REJECT nf_reject_ipv4 xt_tcpudp nft_compat nft_chain_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 nf_tables nfnetlink bridge stp llc binfmt_misc snd_hda_codec_realtek snd_hda_codec_generic ledtrig_audio snd_hda_codec_hdmi nls_iso8859_1 intel_rapl_msr intel_rapl_common snd_hda_intel edac_mce_amd snd_intel_dspcfg iwlmvm snd_intel_sdw_acpi btusb snd_hda_codec snd_seq_midi btrtl kvm_amd btbcm snd_seq_midi_event snd_hda_core btintel mac80211 btmtk libarc4 snd_rawmidi snd_hwdep kvm iwlwifi bluetooth snd_seq snd_pcm irqbypass snd_seq_device rapl input_leds joydev gigabyte_wmi wmi_bmof k10temp ccp snd_timer ecdh_generic ecc cfg80211 snd soundcore mac_hid sch_fq_codel msr parport_pc ppdev lp parport efi_pstore ip_tables x_tables autofs4 btrfs blake2b_generic xor raid6_pq libcrc32c amdgpu hid_generic iommu_v2 drm_buddy gpu_sched i2c_algo_bit drm_ttm_helper ttm drm_display_helper usbhid cec hid rc_core
[sáb dic  2 22:33:22 2023]  drm_kms_helper crct10dif_pclmul crc32_pclmul syscopyarea polyval_clmulni polyval_generic sysfillrect ghash_clmulni_intel sha512_ssse3 aesni_intel sysimgblt crypto_simd cryptd ahci drm i2c_piix4 xhci_pci igc libahci xhci_pci_renesas video ucsi_acpi wmi typec_ucsi gpio_amdpt typec
[sáb dic  2 22:33:22 2023] CPU: 18 PID: 3962 Comm: kworker/u48:61 Not tainted 6.2.0-37-generic #38~22.04.1-Ubuntu
[sáb dic  2 22:33:22 2023] Hardware name: Gigabyte Technology Co., Ltd. X670E AORUS MASTER/X670E AORUS MASTER, BIOS F20a 11/10/2023
[sáb dic  2 22:33:22 2023] Workqueue: events_unbound async_run_entry_fn
[sáb dic  2 22:33:22 2023] RIP: 0010:amdgpu_irq_put+0xa4/0xc0 [amdgpu]
[sáb dic  2 22:33:22 2023] Code: 31 f6 31 ff e9 bd 96 20 cc 44 89 ea 4c 89 e6 4c 89 f7 e8 8f fc ff ff 5b 41 5c 41 5d 41 5e 5d 31 d2 31 f6 31 ff e9 9c 96 20 cc <0f> 0b b8 ea ff ff ff eb c3 b8 ea ff ff ff eb bc b8 fe ff ff ff eb
[sáb dic  2 22:33:22 2023] RSP: 0018:ffffa71b04f37c88 EFLAGS: 00010246
[sáb dic  2 22:33:22 2023] RAX: 0000000000000000 RBX: 0000000000000001 RCX: 0000000000000000
[sáb dic  2 22:33:22 2023] RDX: 0000000000000000 RSI: 0000000000000000 RDI: 0000000000000000
[sáb dic  2 22:33:22 2023] RBP: ffffa71b04f37ca8 R08: 0000000000000000 R09: 0000000000000000
[sáb dic  2 22:33:22 2023] R10: 0000000000000000 R11: 0000000000000000 R12: ffff923ae9574e40
[sáb dic  2 22:33:22 2023] R13: 0000000000000000 R14: ffff923ae9560000 R15: ffff923ae9560000
[sáb dic  2 22:33:22 2023] FS:  0000000000000000(0000) GS:ffff92597e680000(0000) knlGS:0000000000000000
[sáb dic  2 22:33:22 2023] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[sáb dic  2 22:33:22 2023] CR2: 00007f860bf945b0 CR3: 0000001850610000 CR4: 0000000000750ee0
[sáb dic  2 22:33:22 2023] PKRU: 55555554
[sáb dic  2 22:33:22 2023] Call Trace:
[sáb dic  2 22:33:22 2023]  <TASK>
[sáb dic  2 22:33:22 2023]  ? show_regs+0x72/0x90
[sáb dic  2 22:33:22 2023]  ? amdgpu_irq_put+0xa4/0xc0 [amdgpu]
[sáb dic  2 22:33:22 2023]  ? __warn+0x8d/0x160
[sáb dic  2 22:33:22 2023]  ? amdgpu_irq_put+0xa4/0xc0 [amdgpu]
[sáb dic  2 22:33:22 2023]  ? report_bug+0x1bb/0x1d0
[sáb dic  2 22:33:22 2023]  ? handle_bug+0x46/0x90
[sáb dic  2 22:33:22 2023]  ? exc_invalid_op+0x19/0x80
[sáb dic  2 22:33:22 2023]  ? asm_exc_invalid_op+0x1b/0x20
[sáb dic  2 22:33:22 2023]  ? amdgpu_irq_put+0xa4/0xc0 [amdgpu]
[sáb dic  2 22:33:22 2023]  ? amdgpu_irq_put+0x59/0xc0 [amdgpu]
[sáb dic  2 22:33:22 2023]  jpeg_v4_0_hw_fini+0x8a/0xd0 [amdgpu]
[sáb dic  2 22:33:22 2023]  jpeg_v4_0_suspend+0x13/0x30 [amdgpu]
[sáb dic  2 22:33:22 2023]  amdgpu_device_ip_suspend_phase2+0x25d/0x490 [amdgpu]
[sáb dic  2 22:33:22 2023]  amdgpu_device_suspend+0x14e/0x1d0 [amdgpu]
[sáb dic  2 22:33:22 2023]  amdgpu_pmops_suspend+0x38/0xb0 [amdgpu]
[sáb dic  2 22:33:22 2023]  pci_pm_suspend+0x8a/0x1c0
[sáb dic  2 22:33:22 2023]  ? __pfx_pci_pm_suspend+0x10/0x10
[sáb dic  2 22:33:22 2023]  dpm_run_callback+0x54/0x1a0
[sáb dic  2 22:33:22 2023]  __device_suspend+0x14b/0x400
[sáb dic  2 22:33:22 2023]  ? srso_alias_return_thunk+0x5/0x7f
[sáb dic  2 22:33:22 2023]  async_suspend+0x1f/0x80
[sáb dic  2 22:33:22 2023]  async_run_entry_fn+0x33/0x130
[sáb dic  2 22:33:22 2023]  process_one_work+0x21f/0x440
[sáb dic  2 22:33:22 2023]  worker_thread+0x50/0x3f0
[sáb dic  2 22:33:22 2023]  ? __pfx_worker_thread+0x10/0x10
[sáb dic  2 22:33:22 2023]  kthread+0xee/0x120
[sáb dic  2 22:33:22 2023]  ? __pfx_kthread+0x10/0x10
[sáb dic  2 22:33:22 2023]  ret_from_fork+0x2c/0x50
[sáb dic  2 22:33:22 2023]  </TASK>
[sáb dic  2 22:33:22 2023] ---[ end trace 0000000000000000 ]---

You should report this problem to the driver maintainers.

Also, to discard that this could be something caused by something else in your system you can try disabling the integrated gpu in the BIOS settings or by binding it to the vfio-pci driver PCI passthrough via OVMF - ArchWiki and see if you can suspend correctly after doing so.

Did the disable of igpu in bios. Suspend still does not work.
So, re-enable igpu in bios.

Would you know where is the right place to report this problem to the driver maintainers?


Hmmm, did you check if the amdgpu error still showed up in dmesg with it igpu disabled?

Here Issues · drm / amd · GitLab


I did check for the error with igpu disable, and the error ARE there.