KDE neon - Plasma 6 upgrade broke Breeze dark theme in Gtk Apps

Hi everyone,

I’m running the latest KDE neon User Edition. Ever since the upgrade to KDE Plasma 6, Flatpak Gtk applications are displayed in the Breeze light theme, although the system is configured to use Breeze Dark. These applications include at least Slack and Inkscape. Furthermore, Inkscape is displayed in Breeze (the default light breeze), but with Breeze Dark icons, which makes it partly unusable. In the Preferences menu, I can manually switch the theme over to Breeze Dark from the system default theme, from which point Inkscape will begin to be rendered correctly. Other apps don’t have this ability to configure the theme, and I want correct support for the system-wide configuration anyway. Interestingly, Chrome installed from a deb package and configured to use the GTK theme is displayed correctly in Breeze Dark and correctly responds to switching Gtk themes as described in [Electron apps dark theme issue after the latest KDE 6 update]

So, my question is: is it a bug in the Flatpak’s org.gtk.Gtk3theme.Breeze package (which is at version 6.0.3, by the way), Plasma, or the KDE neon? And is there a way around it?

My Breeze Dark theme is not working for Qt apps. Is there a way to reinstall a theme? Maybe that will fix it.

Have a look at bugs.kde.org/show_bug.cgi?id=482182

1 Like

Thanks for the link. I am currently experiencing the comment saying “it cannot be downloaded.” I’ll perform an update and see if the fix gets pulled down.

Pulling the latest updates didn’t fix it. But, I was able to fix by forcing the plasma-integration to the latest version. For some reason, the default wanted to be a 5.x version.

Listing... Done
plasma-integration/jammy 6.0.3-0xneon+22.04+jammy+release+build42 amd64
plasma-integration/jammy 6.0.2-0xneon+22.04+jammy+release+build41 amd64
plasma-integration/jammy 6.0.0-0xneon+22.04+jammy+release+build40 amd64
plasma-integration/jammy 5.27.10-0xneon+22.04+jammy+release+build37 amd64
plasma-integration/jammy 5.24.4-0ubuntu1 amd64
plasma-integration/now 5.19.5-0xneon+20.04+focal+build11 amd64 [installed,local]

And this fix it… if you are having dark themes issues, try this command.

~$ sudo apt install plasma-integration=6.0.3-0xneon+22.04+jammy+release+build42 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following packages were automatically installed and are no longer required:
  kamera libkcolorpicker-qt6-0
Use 'sudo apt autoremove' to remove them.
The following packages will be upgraded:
  plasma-integration
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 151 kB of archives.
After this operation, 34.8 kB of additional disk space will be used.
Get:1 http://archive.neon.kde.org/user jammy/main amd64 plasma-integration amd64 6.0.3-0xneon+22.04+jammy+release+build42 [151 kB]
Fetched 151 kB in 1s (264 kB/s)            
(Reading database ... 576174 files and directories currently installed.)
Preparing to unpack .../plasma-integration_6.0.3-0xneon+22.04+jammy+release+build42_amd64.deb ...
Unpacking plasma-integration (6.0.3-0xneon+22.04+jammy+release+build42) over (5.19.5-0xneon+20.04+focal+build11) ...
Setting up plasma-integration (6.0.3-0xneon+22.04+jammy+release+build42) ...

Regarding my original issue, I created a bug report: bugs.kde.org/show_bug.cgi?id=485028