KDE Neon stuck at OS Selection

I am new to Linux and chose KDE Neon for the environment. After Installation was completed I restarted and got the boot options. However, when I press Enter it gets stuck and does not launch the Neon. How to solve it? I tried from Google but for everyone else, this is happening in VMs and their solutions aren’t working for me. I am a newbie so kindly provide a detailed answer.

Does it completely freeze (so the gear stops spinning)? What’s your hardware configuration? Which option did you select?

It gets past the gear. It is stuck at OS selection. Whatever I select gets it stuck.
image

What do you mean by Hardware Configuration?
If specs then it is i3 and integrated graphics for now. 6GB RAM.

hmm… I thought it’s gonna be some GPU issue. Still maybe worth a try: do you havge “Neon GNU/Linux (safe graphics)” under Advanced options? if so, try that.

Cannot access the Advanced Options either. I can navigate. But the moment I press enter, e or c. it gets stuck

Press Enter, not e or c

I am still stuck there

Is this on real hardware or in a VM?
If real hardware: which Intel i3 CPU exactly - an older one or e.g. 13th generation?

And what were your steps exactly when you installed the system (KDE neon)?
What kind of drive did you install KDE neon to, do you use a GPT or MBR partition table etc. …?

Real Hardware.
Its an older one. 2nd Gen. 3.0 GHz.
I chose the option of install alongside.

On Rufus I did choose MBR. Other then that I was not asked about that as far as I remember.

Just a guess, what if you try recreating the .iso with Balena Etcher or KDE’s ISO Image Writer ?

Alright I am going to try it… will notify the results

1 Like

This is a rather known and annoying issue. Boot with a live ISO, and use Boot Repair to fix Grub.

Will it work for Neon too? The page mentions UBUNTU

@esari Yours didn’t work. File they provide

Tried with a fresh install. It did not work again. Another file from boot-repair

@aronkvh My boot loader is “Master Boot Record” I think it’s MBR? What option should I choose?:
Master Boot Record of {Hard Drive name} (/dev/sda)
Master Boot Record of {2nd Hard Drive name} (/dev/sda) //this one is the main boot one
System Partition
Do not install a boot loader

It did not work, unfortunately. Used Master Boot Record of {2nd Hard Drive name} (/dev/sda) (the main boot one) for boot loader

If your computer is recent enough (64-bit, UEFI - which would be quite all machines from about the last ten years) you should e.g. choose GPT for partition table (not MBR), AHCI for SATA devices (not IDE) and an EFI partition for your boot loader (which will be mounted in /boot/efi in most cases).
Due to the specifics of certain Linux distributions one should use an EFI partition that is at least 300MB in size to be prepared for those cases (but everything >512MB would be excessive and a waste of space IMHO).

But this might beginning to get off topic…

I have run into the exact problem recently and filed the appropriate bug report. In my understanding the bug manifests after the “System Upgrade” package is installed, not just on any type of update/restart. Btw I have tested only using VMs.

https://bugs.kde.org/show_bug.cgi?id=478295

In my case, the whole grub was gone, and the system booted right into KDE Neon, without asking anything. Similar issues i guess. Happened after an update. I thought it happened because i actually did “sudo apt update”. Because it is debian based i thought it wouldn’t be a problem.