KDE Plasma freezes entirely when trying to copy a file from USB memory card

I have two identical 8 GB memory cards, formatted as exFAT and with an identical set of .mp3 and .flac files on them.

They work if I use them in the devices which they shipped with (a couple of identical sleep sound machines). They play the sound files, that is.

But when I mount them in KDE Plasma, which works without delay or issues, and try to drag and drop one of the files from the Dolphin window onto the desktop, the first very transparent frame of what appears to be an animation of a context menu appearing shows up on the desktop where I dropped the file, not showing any context menu items and entirely locking up the entire GUI.

Only by physically pulling out the USB adapter from the USB slot does KDE Plasma return to allowing me to click on anything or interact with it in any way. It’s in a completely frozen state from the moment I have released the mouse button on the desktop (prior to picking anything such as “move” or “copy”).

The LED on the USB adapter which contains the micro memory card blinks as if there’s reading/writing going on, but never finishes unless I jank it out.

I can’t stress enough that this happens prior to any transfer having started, since the context menu which is supposed to show “Move” and “Copy” never shows up. There’s like a “ghost shape” of what is probably meant to be that context menu, but it never “animates” past that first frame.

I used KDE’s own Partition Manager program to format them to exFAT, and was able to transfer the files to them, yet this happens when I try to copy them back. Very puzzling and frustrating.

Important to note is that it seems like certain other files do transfer and don’t cause the freeze, from the same memory cards which exhibit this behaviour.

Usually when this kind of thing has happened in the past, when I ran Windows, it meant that an external HDD or USB memstick was dying or had already died. I sure hope this isn’t the case with these brand new sleep sound machines…

I am experiencing a similar phenomenon. I have a 1TB 2.5" SSD in a USB caddy, formatted as VFAT, which I use to archive material.

I can no longer get access through KDE (though it can be seen in partitioner) and it locks up plasma. Removing the drive returns things to normal.

Again no file transfer was involved. An earlier version of Tumbleweed on another machine works as expected.

This is on Debian, BTW, not that I understand why it would matter.

As a troubleshooting step, can you try selecting the files, copying them with Ctrl+C, and then clicking on the desktop and pasting them with Ctrl+V? Does that work? This is to bypass the code that draws the drag-and-drop menu, which seems like it’s what’s malfunctioning here.

Been saying this since plasma 5.22-ish. There’s a CLEAR difference between desktop as in Desktop and desktop in Dolphin. No, the copy/move service does NOT work on the desktop, it will not show up in the context menu ( that’s exactly WHY I made my own servicemenus for those actions). Regardless what the desktop is set to. No, certain files from an external, although copied or moved, will freeze. You can’t do anything with these files, UNLESS you open desktop in Dolphin. In short, there is something wrong in how the desktop works in KDE. And it has been for a good while now. As an example in the screenshot. The copied files on the desktop are completely frozen. I can not open that folder and the png? I can’t even open it in an image viewer. As a matter of fact, I can’t even move it around.

Whereas, if you open that same file in Dolphin ( ~/Desktop)…no probs.

Now, as stated out by @ngraham , it happens with a drag 'n drop. However, I’ve seen it happen ( as the servicemenu uses the cp command) with a simple copy. But that was really very rare.

1 Like

I have now performed the requested debugging operation. My findings:

  1. First, I tried again to put in the USB device and drag and drop the same big FLAC file (4.3 GB) over to the desktop. The same thing as before happened (entirely frozen until physically unplugged).
  2. Then I tried to do what you suggested (manually copy and then paste the same file onto the desktop). Now it worked; the file started copying with the standard KDE Plasma notification thing and everything. No signs of anything freezing or not working right.
  3. I also tried to drag and drop another, much smaller (11.2 MB) FLAC file from the same device onto the desktop. This time, it did not freeze! Instead, it showed the context menu item with the “Move”, “Copy”, etc., and I was able to move the file without issues. Very bizarre. It seems like it somehow has to do with the size of the file?

File system: exFAT. Formatted using the KDE partition manager.

I agree that there is something very wrong related to the desktop in KDE Plasma. Numerous of my problems seem to stem from weird differences in how the desktop is treated versus Dolphin views. It’s frustrating to say the least. Hopefully it will all be fixed in 6.

At this point I think you’ve discovered an un-handled edge case somewhere, so I’d recommend you submit a bug report about it so it can be investigated further. Thanks.