KDE Plasma6, upgrade, FreeBSD, caveats

For anyone upgrading from plasma5-plasma to plasma6-plasma on FreeBSD.

Be sure to disable the autologin feature in the sddm systemsettings or you might be stuck with a black screen, because plasma6 on FreeBSD also seems to default to a wayland session, which isn’t really working on FreeBSD (at least on my machines :-).

To login to plasma6 you need to switch the user session back to “plasmax11” to get a working desktop. If you forgot, you need to edit your /usr/local/sddm.d/kde_settings.conf manually

Another caveat: a lot of tools like dolphin, okular and gwenview are still dependent on kf5 and plasma5 on FreeBSD. You need to use their *-devel counterparts. Some other applications like e.g. audacious or pdfmixtool have a *-qt6 version.

if you are missing or have some wrong icons make sure you have kf6-breeze-icons installed

One more caveat concerning synaptic touchpads:

The configuration in plasma5 also used on the xf86-input-synaptics module. In plasma6 it’s done by libinput.

If you get no touchpad options in systemsettings after the upgrade you need to make sure xorg uses the libinput driver instead of the synaptics driver for your input devices.

I wasn’t able to change priorities or to cleanly deinstall the xorg synaptics package without breaking other things. But a quick and dirty “pkg delete -f xf86-input-synaptics” did the trick.

Unfortunately even some plasma6 packages pull the synaptics driver as a dependency, so after upgrading these packages you might need to repeat removing the synaptics driver.
(yeah, ugh… don’t try this at home, kids:-)

hope it helps to get you going…