KDE System Settings window is not changing theme

When I change the theme, the KDE system settings window does not change.

For some reason, it is using a dark theme window with a light theme font - so I cannot read the settings. And when I change the theme, the System Settings window doesn’t change at all.

For example, above there is text in that red box, just not legible.

It must be a system-wide setting somewhere, as I tried it with a fresh /home/profile folder too but it’s still the same.

Anyone able to offer some guidance on what can be done here?

It turns out this is happening in Discover as well. But most other applications are ok.

not all themes are created equal… and some leave bits behind even when they are uninstalled.

your current theme may be in conflict with some bits left behind by another theme giving you this undesirable result.

go to each of these settings pages and delete/uninstall themes you are not using and reset everything to breeze or the defaults.

  • Appearance > Global Theme
  • Appearance > Plasma Style
  • Appearance > Colors
  • Appearance > Windows Decorations
  • Appearance > Icons
  • Appearance > Cursors
  • Appearance > Splash Screen
  • Startup and Shutdown > SDDM

then try your chosen theme again.

Thank you for your response! You put me on the right path with removing and reinstalling the themes and defaulting all their settings.

That ended up leading me to the /etc/environment file.
It turns out that there was an entry in there to set the QT_QPA_PLATFORMTHEME environment variable.

Once I removed that - everything went back to normal.



glad it worked out.

Yep, thaat’ll do it.