KDE: XCURSOR_THEME resetting to breeze_cursors on reboot

Does anyone have any idea why my cursor would be resetting itself on every reboot, it’s driving me insane at this point.

If I pick my preferred cursor (McMojave_cursors) from the system settings, something switches it back to breeze_cursors on reboot.

OS: Arch Linux x86_64 
Kernel: 6.6.4-arch1-1 
Shell: zsh 5.9
DE: Plasma 5.27.10 
WM: KWin

I update the environment variable:

export XCURSOR_THEME=McMojave-cursors
set XCURSOR_THEME=McMojave-cursors

It works for the session, then something switches it right back on reboot.

I’ve added the file:

[Icon Theme]

it gets switched back on reboot.

I’ve added (same file contents as above):

it’s switched back on reboot.

The result of printenv after a reboot shows:

$ printenv | grep CURSOR

I also added the environment variable XCURSOR_THEME=McMojave-cursors to /etc/environment, didn’t help unfortunately.

I just can’t work out what’s altering this environment variable and I’m going mad.
This only started happening in the last couple of weeks.

The frustrating thing is I can see the correct cursor is set when the OS first boots.
Before the little animated boot screen on KDE the first thing to appear is the cursor and it’s the correct one, then after the boot animation it switches to breeze.

Anyone have any clues as to where I should look?

Web searches always only seem to bring up “My cursor changes when I hover over X application”, seemingly no mention anywhere of anyone else having the cursor being switched by something.

Thanks in advance for any ideas!

I thought the problem had gone away, but it hasn’t.

I took the step of deleting /usr/share/icons/breeze_cursors folder.

$ sudo rm -r "/usr/share/icons/breeze_cursors"

the environment variable is still set:

$ printenv | grep CURSOR        

however, SDDM seems to step in now and change it to the default cursor.

$ journalctl -b | grep cursor   
Dec 09 11:05:02 main sddm[3050]: Setting default cursor

and my cursor seems to be sticking after multiple reboots.

If anyone has any idea how to fix this properly then let me know, thanks.

This sounds a bit like an X/Y problem question to me. Can you back up and explain the specific problem you experienced that prompted you to try this manual workaround which isn’t working?

Hi ngraham, thanks for taking the time to look at this and apologies if my post is a mess.

Basically about a week ago (sorry I can’t be more specific!) when booting into KDE I noticed my mouse cursor had set itself to breeze_cursors. So I set it back to McMojave and didn’t think anything of it.

Since then, each time I rebooted, the cursor would reset itself to breeze_cursors.

When setting the cursor to McMojave in the System Settings panel, the setting wouldn’t persist across reboots.

I checked the printenv output after a reboot and I would see the following variable set:


That’s where I got up to basically. I’ve been trying to figure out what was setting that environment variable and how I could either stop it or correct it.

My original post details the steps I’ve taken to try and correct it. So far only deleting the breeze_cursors folder completely from /usr/share/icons/ seems to have worked.

I wasn’t able to find the info I needed on the Arch Wiki and the KDE help page I visited details changing the cursor via the GUI.

Before your troubleshooting, did you have anything set in any config files that might be overriding your choice of Mojave Cursors?

I’ve not done anything specific regarding cursors and config files. I’d always set it via the system settings panel.