Kdeconnect (1.26.0) "Run Command" widget disappeared from android's homescreen. Put back, but now blank. However, can still run commands from app

So a bit ago, the kdeconnect “Run Command” widget disappeared from my android phone’s homescreen.

I was able to put it back
(in the normal way I found and positioned the widget in the first place, a while back),
but the widget displays only a blank empty box inside now.

However, I can still run my commands from inside the app.

I would guess this happened with an update to my android
I’d think it’s nothing to do with the kdeconnect running on my computer, right?
– if it is relevant, the computer is openSUSE tumbleweed,
so kdeconnect.app 23.04.2 right now,
and it’s xorg, not wayland
but unfortunately the updates on my android are automatic and I don’t even know how to find any useful logs for it.

All I can say is the version on the phone says 1.26.0.

Should I report this as a bug or something?
I’m new to the kde community, so not sure how things work.
I feel like I should provide more useful information if I’m gonna report it as a bug,
but I’m not sure how to find any more useful information on this.

Try tapping the header at the top of the widget, where it say “KDE Connect”. This should bring up a device selection popup.

It will show paired devices. You have to select one, even if there is only one paired device, iirc.

1 Like

I’m not sure how to take a screenshot of this on my phone,
but that just activates the generic android “reposition or remove this homescreen element” functionality.

ie, the header doesn’t seem to have any active functionality different from anywhere else on the widget.

I finally tried just uninstalling kde-connect from the phone,
and then reinstalling it.

I decided to do the reinstall using F-Droid
(rather than the google “play store” like I did when I first installed it).

I had to manually set all the configurations back up,
including setting up the commands on my computer,
and giving it each permission again on the phone,
but the “run command” widget works again.

I note the version on the phone is now only 1.24.5
(I guess F-Droid is behind?)

I would test if the problem is also fixed if I reinstall from the google “play store” as well
(presumably that would get me back to 1.26.0)
but I really don’t want to go through setting everything back up again right now.

I guess I’ll probably just call this done for now,
and hope the problem doesn’t reoccur when the F-Droid version catches back up to 1.26.0?

@claydoh btw it just occurred to me,
maybe the reason the header doesn’t have any different functionality than the rest of it
is cuz I only have one device connected to the phone?
to be clear,
the header still doesn’t have any different functionality,
even now that it’s working again
(ie, has the commands list back, no longer a blank empty box)

When I have only one device paired, I still need to set it that way, if memory serves, the first time I use the widget on my phone.

1 Like

Hm, now I’m wondering if there’s a difference in just something in the android system,
or in the kdeconnect app itself.

Just out of curiosity, could I trouble you to tell me the version number of your kdeconnect app? Thanks!

1.26.0 on Android 13.

1 Like

Huh, so exactly the same as me then. (Well, before I ended up with the downgrade to 1.24.5.)
I guess the difference is caused by something more specific then,
like some particular detail of how the manufacturer modified my phone’s android system from stock…

It acts identically on my Android 10 backup phone (V30 with Lg’s skin) as it does on my Pixel 7.
I initially need to tap the widget’s header on the homescreen, and select a device, even if there is only one paired. After that, it isn’t necessary, unless you want to switch to a different paired device.

1 Like

Huh. Well, I have a samsung (“Galaxy S21 Ultra” I think),
and I vaguely remember hearing they make modifications to the stock OS that are a bit weird?
(But like, I only started using a proper smartphone in the past couple years, so I really know very little on the subject.)

However, coincidentally,
when I woke up this morning there was a notification from F-Droid saying there was an update for kde-connect,
back up to 1.26.0.

Oddly, the first time I tried to accept the update,
it failed (something about an error parsing the package?)

But then I simply tried hitting update again,
and it worked that time.

After the update,
the widget disappeared from my homescreen again,
but this time when I put it back,
the widget header was functional.

The release notes said:


  • Allow having different widgets for different devices.

so I guess the bugginess in my update the first time was maybe related to that…