Kden live openai-whisper unable to install

Hey, i am using the appimage version, running that on a debian. Keep getting this message. Clicking on Install missing dependencies didn’t do anything, done that a couple times. Before it also complained about other deps, but installing them through:

sudo apt install python3-srt
sudo apt install python3-torch

Solved the problems, but with whisper:

sudo apt install python3-openai-whisper
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package python3-openai-whisper

Don’t really have an idea how to fix that, would be greatfull for some help

Define “a couple times”. It took me about 8-10 clicks to finally get the success message. Keep hitting the “Install missing dependencies” button - you’ll get there eventually.

Pressed it like 20 times, that’s a couple times for me. Right now i just pressed it another 50 times, and it did absolutely nothing, just almost instantly returns back the message that this module is needed

1 Like

You ever get it working?

Got it working by creating a venv and running kdenlive while it is active :slight_smile:

python3 -m venv myenv
source ~/myenv/bin/activate


Thanks for sharing your solution, @Gal_Zakay

Whisper install seems to hang up on this dependency.
I’ve tried reinstallation of dependencies 4 times now, it gets stuck in the same position.

Using cached nvidia_cuda_runtime_cu12-12.1.105-py3-none-manylinux1_x86_64.whl (823 kB)

Downloading nvidia_cudnn_cu12- (731.7 MB)

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━╸ 691.9/731.7 MB 1.5 MB/s eta 0:00:27

Installing missing packages: {‘torch’, ‘openai-whisper’}

Downloading nvidia_cudnn_cu12- (731.7 MB)