Kdenlive 23.08.0 released

Originally published at: Kdenlive 23.08.0 released - Kdenlive

We’re excited to present the latest version of Kdenlive, packed with an array of fixes, enhancements, and optimizations. Some highlights include: 2 new effects, Audio Seam and Auto Fade, which can be added to tracks to eliminate audio cracks which might happen with some clips such as MKV and FLAC New AV1 NVENC profile Fixes…


Your decision to make a lot of small improvements and fix bugs instead of adding new features to Kdenlive is really good.
Big thanks to the developers.


Attention, there is a trap that you can easily fall into:
When rendering there is now the following option: This is unfortunately switched on in the new version 23.08.0:
Guide Mulit-Export

When this is ON, Kdenlive renders everything in small sections. Of course, if you’re not used to that, you’ll think: Oh, another fat bug. But only when I turned it off, everything was back to normal.

I’m sure that some people will have problems with this at first, at least it was like that for me.

It is off by default in my version (23.08.0 Linux appimage)

On my AppImage it is also turned off by default - if there are no markers (G) in the project.
But if I insert markers before rendering, it is switched on again.

Have tried several projects: Some have it turned on, some don’t.
Not so bad, only the one where it is on should quickly realize what is going on and that he can simply turn off this function that never existed before.

Just opened more old projects: Always the same:

If you open a new or old project and first insert one or a few markers (G) and then click on Render, it is on.

If you click on Render in a project without markers being there, it is off, of course. If you insert a marker after the first render, then it stays off for the next render.

All not so bad if you know how to handle it.

on Windows version is enabled by default:

1 Like

sure that you have not deleeted the kdenliverc file before using the latest version?

Is it recommended to delete the kdenliverc after an update? I have never done this before.

usually to prevent issues related to new settings (that was not present before) and when switching to a major release (22.08 -->22.12–>23.04 … etc etc)
better to “purge” configurations files… but no idea if this is necessary using appimages.

I usually do not use AppImage. And how to “purge” this kdenliverc? And, as I said, I have never done this before.
If you delete the kdenliverc (or just rename the old one so that a new one is built), does it keep all the effect settings and shortcuts? Because I don’t want to reconfigure them all the time.

It is not necessary to reset the settings between releases. This issue is fixed in next release.

1 Like

In kdenlive-master-696-linux-gcc-x86_64.AppImage it is already fixed.
Thank you.

I usually use AppImages in order to get the latest version, repositories often have only old versions of software.

Yes, AppImages are always very up-to-date. But since I use Manjaro Linux, my repositories are also always pretty up to date. Also, with the AppImages, I don’t have all my installed effects readily available.

I use AVL-MXE Linux and also Windows 11 22H2, so I am able to use Kdenlive in both Windows 11 and Linux.

If you have never heard of AVL-MXE Linux, you can take a look at the AVL-MXE Linux website here AVL-MXE Linux website

1 Like

Thanks for the great editor!
It’s a pity that the ability to create projects with multi-channel audio remains broken, regardless of the settings; you can only create a project with stereo tracks.

Maximum possible audio channels are 6. This is a MLT limitation (MLT = framework on which Kdenlive is based on).
Details see here → “Audio channels”: Configure Kdenlive — Kdenlive Manual 23.08 documentation

Yes, that’s right, 6 channels are enough. But the problem is that in the latest versions the ability to create new projects with 6 channels does not work; regardless of the settings, you still end up with a project with only 2 channels.

I see, even when you have set 6 channels in the settings a fresh started Kdenlive has only 2 channels. That seems to be a bug.
Workaround: start Kdenlive → Ctrl+n opens a new project (again) and you should have 6 channels or the possibility to change to 6 channels.

1 Like

The workaround works, thanks a lot!