kdenlive-23.08.4-x86_64-A.AppImage not start in Lubuntu 20.04.6

Thanks for reading my topic.

Lubuntu 20.04.6 ( Ubuntu using LXQT). Glibc 2.31.

Trying load kdenlive-23.08.4-x86_64-A.AppImage not start.

In terminal is showed the message

./kdenlive-23.08.4-x86_64-A.AppImage
The X11 connection broke: No error (code 0)
XIO: fatal IO error 39 (Directory not empty) on X server “:0”
after 349 requests (349 known processed) with 0 events remaining.

kdenlive-23.08.1-x86_64.AppImage start correctly.

./kdenlive-23.08.1-x86_64.AppImage
Loaded icon theme: “breeze”
Loaded icon theme: “breeze-dark”
Starting render server
profilePath from $MLT_PROFILES_PATH: “/tmp/.mount_kdenliMQTDfK/usr/share/mlt-7/profiles/”
meltPath from KdenliveSetting::meltPath: “/tmp/.mount_kdenliMQTDfK/usr/bin/melt”
Empty metadata for “glsl.manager”
Empty metadata for “telecide”
plugin not available: “avfilter.acompressor”
plugin not available: “avfilter.aecho”
plugin not available: “avfilter.agate”
plugin not available: “avfilter.atadenoise”
plugin not available: “avfilter.bs2b”
plugin not available: “avfilter.bwdif”
plugin not available: “avfilter.deblock”
plugin not available: “avfilter.dedot”
plugin not available: “avfilter.deflate”
plugin not available: “avfilter.derain”
plugin not available: “avfilter.doubleweave”
plugin not available: “avfilter.field”
plugin not available: “avfilter.framestep”
plugin not available: “avfilter.fspp”
plugin not available: “avfilter.graphmonitor”
plugin not available: “avfilter.hqdn3d”
plugin not available: “avfilter.inflate”
plugin not available: “avfilter.lagfun”
plugin not available: “avfilter.loudnorm”
plugin not available: “avfilter.mcdeint”
plugin not available: “avfilter.random”
plugin not available: “avfilter.removegrain”
plugin not available: “avfilter.separatefields”
plugin not available: “avfilter.shuffleplanes”
plugin not available: “avfilter.sofalizer”
plugin not available: “avfilter.sr”
plugin not available: “avfilter.tmix”
plugin not available: “avfilter.w3fdif”
plugin not available: “avfilter.weave”
plugin not available: “avfilter.yadif”
plugin not available: “frei0r.baltan”
plugin not available: “frei0r.bgsubtract0r”
plugin not available: “frei0r.delay0r”
plugin not available: “frei0r.delaygrab”
plugin not available: “frei0r.lightgraffiti”
plugin not available: “frei0r.lightgraffiti”
plugin not available: “frei0r.tehRoxx0r”
plugin not available: “ladspa”
plugin not available: “ladspa”
plugin not available: “ladspa”
plugin not available: “ladspa”
plugin not available: “ladspa”
plugin not available: “ladspa”
plugin not available: “ladspa”
plugin not available: “ladspa”
plugin not available: “ladspa”
plugin not available: “ladspa”
plugin not available: “ladspa”
plugin not available: “movit.unsharp_mask”
plugin not available: “timewarp”
plugin not available: “region”
kf.config.core: “KConfigIni: In file /usr/share/applications/screensavers/glitchpeg.desktop, line 7: " Invalid entry (missing ‘=’)
kf.service.sycoca: Service type not found: “application/x-kdenlive”
=== /// CANNOT ACCESS SPEECH DICTIONARIES FOLDER
ALSA lib /home/appimage/Craft/BC/linux-64-gcc/build/libs/libasound2/work/alsa-lib-1.2.5.1/src/conf.c:4499:(snd_config_update_r) Cannot access file /home/appimage/Craft/BC/linux-64-gcc/share/alsa/alsa.conf
no alsa devices available
ALSA lib /home/appimage/Craft/BC/linux-64-gcc/build/libs/libasound2/work/alsa-lib-1.2.5.1/src/conf.c:4499:(snd_config_update_r) Cannot access file /home/appimage/Craft/BC/linux-64-gcc/share/alsa/alsa.conf
no alsa devices available
QQmlEngine::setContextForObject(): Object already has a QQmlContext
QQmlEngine::setContextForObject(): Object already has a QQmlContext
QQmlEngine::setContextForObject(): Object already has a QQmlContext
QQmlEngine::setContextForObject(): Object already has a QQmlContext
kf.solid.backends.udisks2: Failed enumerating UDisks2 objects: “org.freedesktop.DBus.Error.Disconnected”
“Not connected to D-Bus server”
kf.solid.backends.udisks2: Failed enumerating UDisks2 objects: “org.freedesktop.DBus.Error.Disconnected”
“Not connected to D-Bus server”
kf.solid.backends.udisks2: Failed enumerating UDisks2 objects: “org.freedesktop.DBus.Error.Disconnected”
“Not connected to D-Bus server”
kf.solid.backends.udisks2: Failed enumerating UDisks2 objects: “org.freedesktop.DBus.Error.Disconnected”
“Not connected to D-Bus server”
kf.solid.backends.udisks2: Failed enumerating UDisks2 objects: “org.freedesktop.DBus.Error.Disconnected”
“Not connected to D-Bus server”
kf.solid.backends.udisks2: Failed enumerating UDisks2 objects: “org.freedesktop.DBus.Error.Disconnected”
“Not connected to D-Bus server”
kf.solid.backends.udisks2: Failed enumerating UDisks2 objects: “org.freedesktop.DBus.Error.Disconnected”
“Not connected to D-Bus server”
kf.solid.backends.udisks2: Failed enumerating UDisks2 objects: “org.freedesktop.DBus.Error.Disconnected”
“Not connected to D-Bus server”
:::: NOT FOUND DOCUMENT GUIDES !!!
!!!
QQmlEngine::setContextForObject(): Object already has a QQmlContext
qrc:/qml/timeline.qml:502: ReferenceError: proxy is not defined
qrc:/qml/timeline.qml:482: ReferenceError: proxy is not defined
==== NO PREVIOUS TIMELINE
::::::::::: connecting timeline: QUuid(”{0b65daf3-18fb-4d28-84ff-c22c3dfd55de}") , DUR: 0
root context get sub model new function
HHHHHHHHHHHH
INVALID BIN PLAYLIST…
=== OPENING FILE WITH TRACKS: 5
:::: FOUND TRACTOR WITH TRACKS: 2


=== MODEL DATA CHANGED: MUTE DONE TRACK NOT FOUND!!!
:::: FOUND TRACTOR WITH TRACKS: 2


=== MODEL DATA CHANGED: MUTE DONE TRACK NOT FOUND!!!
:::: FOUND TRACTOR WITH TRACKS: 2


=== MODEL DATA CHANGED: MUTE DONE TRACK NOT FOUND!!!
:::: FOUND TRACTOR WITH TRACKS: 2


=== MODEL DATA CHANGED: MUTE DONE TRACK NOT FOUND!!!
===== ACTIVATING DOCUMENT: QUuid(“{0b65daf3-18fb-4d28-84ff-c22c3dfd55de}”)
::::::::::::::::::::::

kdenlive-23.08.4-x86_64-A.AppImage not is compatible with Ubuntu 20.04.6 ?
Have an nice day.

Wow, is KDEnlive 23.08.4 not available in the repositories?

Maybe the issue is that Lubuntu is a ‘stable’ distribution offering older software… one reason I changed my distribution.

I think you can choose appimage, flatpak and PPA.

Try again.

PPAs for 4 Ubuntu versions

23.08.4 not is available in PPA for Ubuntu focal 20.04.6.
I had used the appimage without any problems.
Recent appimage not works in 20.04.6.

Lubuntu not is an stable old distribution.
I only use the 20.04.6.
Current Lubuntu versions are available.

Appimage doesn’t work for me either (Manjaro KDE Testing)

./kdenlive-23.08.4-x86_64-A.AppImage 
Loaded icon theme: "breeze"
Loaded icon theme: "breeze-dark"
 = = = =
GOT Deleted file:  "/home/ben/.config/kdenlive-appimagerc"
 = = = =
GOT Deleted file:  "/home/ben/.local/share/kxmlgui5/kdenlive/kdenliveui.rc"
QPaintDevice: Cannot destroy paint device that is being painted

Ubuntu Jammy is 22.04 - that’s the oldest version supported by the PPA if you read the options there - Jammy Jellyfish, so you have to use the older version of kdenlive in the repository I think.

Ubuntu 20.04 has kdenlive 19.12.3