Kdenlive 24.02.0 RC ready for testing

Originally published at: Kdenlive 24.02.0 RC ready for testing - Kdenlive

Kdenlive development has been very active since our November sprint focusing on the 24.02 KDE Mega Release, that will be based on Qt6 (but is still compatible with Qt5) and KF6. In addition to the essential porting tasks, we dedicated efforts to fixing numerous bugs to enhance stability and introduced some exciting new features, which…

1 Like

Please leave your comments in this post below.

I loaded up a recent project (using AppImage version) just to see what would happen and got a bunch of notifications at the start. In case it’s useful, I thought I’d post some screenshots.

Also, thought I’d mention that I really like the aesthetics on this update, but some of the UI is difficult for me to discern on Breeze Dark. Mainly, certain buttons are minimally distinct from the general darkness of the window. Maybe the location for certain buttons are exceptionally harder to see because of the poorer contrast towards the edge of my monitor.

Hello,
I have started trying different things to test the new versions, and I’m writing notes for the café (unless you’d rather i post them here in advance?). But one big thing is that my mouse stays in the spinning blue circle mode on windows, no matter what I do, from when I open kdenlive to when I close it. It’s never happened with orevious versions or other softwares

Thanks for the feedback, can you please share your project file?

Feel free to post them here, maybe they’ll get fixed sooner. Will be great to have you at the Café. :slight_smile:

1 Like

Are You on Windows? If so, this is a known issue. As soon as you open a project file the spinning mouse should change to an arrow.

With the new version we have implemented an in-deep check for corrupted project files. It seems your project have some issues. When you finally open the project is everything as it should be?

This link will expire February 17, 2024: projectfile.kdenlive

It looks like the most recent sequence of a cut plays as usual. I noticed that after these initial messages, a couple previous sequences of earlier revisions were opened automatically.

It’s been a while since I looked at them, but checking one of the sequences it opened, it appears an audio track (#4) was missing, and browsing through, one apparent oddity is that I can see a clip appears to have replaced another. I rendered a video of this area of the timeline.

Here is that same area in the final video that was already rendered days ago.

And the clip that was moved into this area of the timeline from earlier in the video (removed link due to new user restrictions).

https [colon forward-slash forward-slash] ody [dot] sh/XvRuNTsLQg?t=47

This is just from a quick skim trying to see if there were any issues.

Thank you for Kdenlive, I really like the program.
I was very pleased with the new release :pray:

1 Like

Yup, on Windows, I figured it might have been known since it’s very noticeable.

Ah, makes sense why it never went away, I didn’t open a project file and just started playing around

Hi

Windows 10. 7 year old Acer laptop.

Issues I’ve had are

  1. External monitor. Plasma screen connected to laptop by hdmi cable. In this RC version when I go to full screen, screen goes white. Normal screen shows either clip monitor or project monitor as white also. Needs restart.

  2. Two proxied clips had frozen later on in the clips. Lucky the original clips play ok. So the render was safe.

  3. My shortcut to extract a PNG frame did not work. Had to use render to get around this.

  4. The notifications did not have the Speak Event Name option.

  5. Reopening the project caused corrections to made and explained in Project Notes. When these were inspected manual corrections weren’t allowed and caused the system to crash.

Hope this is useful. I’ve gone back to the latest nightly build for my next project. I did complete my project with the RC and it will be ready for viewing on Monday 5th February 1800 GMT.

1 Like

Hi, i’m not 100% sure where the issue comes from, but I went back to 23.08.4 to edit on something more stable, and the Effects and Compositions tabs are totally empty and white. I’ve tried emptying the cache, reset configuration and uninstalling and reinstalling again, and nothing solved it.


I’m gonna try another older version but other than that i don’t really have ideas…
Oh and still on Windows 10

Edit : Solved it! the solution (i think) ended up being installing 24.02, uninstalling it, then installing 23.08. The first time I didn’t uninstall 24.02 manually

I have noticed a two/three potential regressions from 23.08.04 as outlined below, as well as some minor differences:


Full screen image is offset:

I noticed someone mentioned full screening in the telegram chat so tried to replicate their issue, which I could.

I have 2 monitors above/below eachother, but I think this might apply with only one monitor as well:

When I double click the viewport to make fullscreen this is what I get in the konsole:

begin
OpenGL vendor "AMD"
OpenGL renderer "AMD Ryzen Embedded V1605B with Radeon Vega Gfx (raven, LLVM 16.0.6, DRM 3.49, 6.1.74-xanmod1)"
OpenGL threaded? true
OpenGL ES? false
OpenGL maximum texture size = 16384
OpenGL maximum viewport size = 16384 x 16384
end

The result is the same for Clip/Project Monitor.


Lift/Gamma/Gain (Color Wheels) often is unresponsive:

When I try to change any parameters in the effect I end up dragging some part of the gui instead. Also, if I hover over the vertical intensity bar of any of the three wheels and scroll up/down nothing happens.


The result is the same whether I am in the Editing or the Color grading interface.


Slip tool not slipping sometimes

I have not managed to reproduce this issue to show it but sometimes when I go into the slip tool the GUI will change but the IN/OUT points will stay the same and the “underlying” clip won’t move.

Will try to replicate some more and post a gif here. Seems similar to the Lift/Gamma/Gain issue where the interface is thinking I am doing something different to what I am.


Minor things that might not be related to this rc / bugs / regressions

GUI change?

not sure this is just difference between AppImage and nixpkgs version, or a Qt6 vs Qt5 change, but the gui seems to have slightly less rounded edges, less padding, etc.

RC:

vs.

Stable

(ignore the color difference in the project monitor. The screenshot in the stable version is from the project file before versioning it prior to testing the RC, so is lacking the Color grade on a few clips.)

I do like the new GUI better =D

Speech-to-text

I haven’t used this since I moved to NixOS and there seems to be no difference between the RC Appimage and the Stable nixpkgs version. However, when I am in the Whisper menu, kdenlive is unable to find the GPU and is just “Probing” for device to use indefinitely.

I can use VAAPI rendering in both the RC Appimage and the Stable nixpkgs version, so not sure why it is unable to find it. This might be something NixOS related so will investigate further and possibly report there.


That is it for now I think, I’ll have a go at rendering some stuff and edit some more in this version.

In this stage of the project I am editing I am mainly fine-tuning exact in and outs of the clips, the edit is more or less done so having the Slip tool and Color grading misbehaving sometimes is quite frustrating as they are the two tools I am using the most.


System Info

Operating System: NixOS 23.11
KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.113.0
Qt Version: 5.15.12
Kernel Version: 6.1.74-xanmod1 (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen Embedded V1605B with Radeon Vega Gfx
Memory: 14.6 GiB of RAM
Graphics Processor: AMD Ryzen Embedded V1605B with Radeon Vega Gfx
1 Like

Thank you for reporting.

Point 1 seems to be a bigger issue on Windows. When double-click either the clip monitor or the project monitor it gets white on the second screen and you see no playback. Hit ESC and the monitor get back into original position but it’s still white and you see no playback.

I get this message on DebugView:
[2348] qrc:/qml/kdenliveclipmonitor.qml:612:29: QML Rectangle: The current style does not support customization of this control (property: “background” item: QQuickRectangle(0x2aaa0407a20, parent=0x0, geometry=0,0 0x0)). Please customize a non-native style (such as Basic, Fusion, Material, etc). For more information, see: Customizing Qt Quick Controls | Qt Quick Controls 6.6.1

Point 2 and 3 maybe related to this playback issue.

1 Like

Is there a Windows Standalone Version 24.02.0 RC I can test?

Yes. I’ll upload it, so you can reach it from the News page by tomorrow.

Running the AppImages on Debian 12.

I’m seeing lots of GUI weirdness, especially with the Breeze Dark theme. Sometimes the theme doesn’t stick until I set it a couple of times. And some of the icons have very low contrast. This is from the RC:

new

And this is from 23.08.4:
old