Kernel update to 6.1.0-18 broke my system-Nvidia Driver

I have and AMD system with RTX 4060 video card. After much gnashing of teeth and kicking the dog I finally got tit to work by installing the NVIDIA driver. (the nouveau driver doesn’t work, something to do with the mode).
So I installed the NVIDIA 535 driver (the 525 driver is pretty dodgy and the 535 driver fixed most of my issues). (yes I had to install it with the .run file from nvidia)
All working fine.

But with the upgrade I cannot boot. I cannot reinstall the nvidia driver either.
I can still boot and run in the 6.0.1-17 kernel using the advanced options.

If the kernel changed enough that the compiled driver is no longer correct then I would have thought it would just be a matter of re installing.

Am i missing something obvious?

(the dog is fine its rhetorical anyway)

545 is “new feature branch” version, whereas 535 is “Production”. Expect issues when using versions that NVidia isn’t confident in promoting to Production.

Actually, expect issues in all versions of Nvidia drivers. But especially in non-Production versions.

Thanks for the reply @dirthsj .

I think it is now a production. There are at least 2 or 3 more, the last 2 are beta and development.
I have since found it is a problem with the Debian upgrade. It is a dependency issue.
It not only affect 6.1.0-18 but at least a couple of the later kernels. (though strangely not all).
Presumably, it will be fixed with a patch of some sort soon.
I can either roll back to 6.1.0-17 which I have working with the 545 driver, or just put up with and do a selection of of 6.1.0-17 at boot.
There is no alternative other than the nvidia driver because the nouveau driver wont work.
I think that is to do with modes or resolution set at boot. ( I have other linux installs with Nvidia drivers so I don’t think I can can’t mix and match without much angst & I have tried)

You seem to use Debian 12 - this is a known bug, see:

As you wrote you could use the previous (6.1.0-17) kernel.
With such a new graphics card you should also consider using the 6.5.x kernel (and headers) etc. from the Debian Backports (see:, which should also fix the current Nvidia issues (but be aware that kernels from Debian Backports lag behind concerning security patches!).

In the long run I had made the experience that one should also always try to use the Nvidia drivers that are provided directly by the distribution one uses, which leads to less problems. Installing Nvidia drivers from 3rd-party sources (e.g. the .run from Nvidia) can bite a lot of people in the a** one day.

That said: all in all consider switching to a distribution that has newer kernels, firmware, Mesa and Nvidia drivers for something like the RTX 4060 - like TUXEDO OS 2 or openSUSE Tumbleweed - as much as I love Debian: it is not very suitable for newer hardware…

And consider buying an AMD or Intel graphics card next time if you don’t rely on CUDA… :wink:

1 Like

It is not. You can see exactly what version is production on this page.

Thank you for the reply @dirthsj
You are absolutely correct, my bad.
The 535 worked fine for me so I then went to the 545 and that seems OK as well.
None work with the 6.1.0-18 update.

Thanks for the reply @schwarzerkater
There was/is a discussion about the same bug affecting the backports, but I think the solution was found (and pushed) pretty quickly.
I prefer to stick with the more stable versions, though I guess “stable” is relative these days with such rapid advances in both hardware and software.
I could go to windows 11 to fix the issue as well. (just being facetious)

I will mark this as the solution, because the solution is not related to KDE, but to the underlying kernel.
There are a couple of ways to mitigate the problem but I intend to wait for Debian to release a solution so I wont (hopefully) encounter problems down the track with any of these mitigations. :grinning: