Kleopatra for windows - import fail

Kleopatra 4.2 installed on windows 11, been working fine in the past.

today went to verify a file from a publisher i’ve previously verified with successfully.

  1. the certificate is not listed with the my others under “all certificates” or anywhere i can find
  2. trying to import the certificate fails with 0 imported
  3. when importing → details → certify → message says “no updates” implying the certificate is already imported??

Ok appreciate any light on this subject.

ok, i’ve located the key under
however, i couldn’t find an actualy gpg.conf file pointing to anything, sooooooo uhhh. yeah. progress anyway, probably found the problem??

deleting the private key and then importing worked.

no idea what caused the problem, but everything is as it should be again.

lol… edit:

it’s solved, but lol. i deleted my private key when i deleted the keys in there so i couldn’t certify the imported certificate, i had to restore the files and then certify. brain fried. problem solved.