KMM 5.1.3 & plasma 6

Mapping account returns “sorry no suitable account listed in this bank”. This happens after entering correct user name and password for the bank login. KMM 5.0.2 returns account list following the same approach. Any suggestions?

Note that KMyMoney has not yet been ported to Qt6, so although your main system may be plasma 6 based, KMM is still using version 5 frameworks and libraries. However, I cannot think of anything which should have changed this behavior in any way. I’m not sure what translation is involved, but basically it is the bank that says there are no suitable account for that username/password combination.

I don’t know if it matters, but which distro/OS are you using, and where did you download your copy of 5.1.3? It is possible for you to try an appimage or flatpak version? You can also try running KMyMoney from command line, just in case any error message might show up on console, although I don’t expect anything useful there.

Another question would be, which online backend are you using? OFX or KBanking?

I tried KMM flatpak which worked but with a few problems.

Installed the snap package whch runs perfectly.

Hi every body! I have been busy searching and learning how I could resolve the issue to no avail. However, For me, I found a way to get around it. Here is the story. My main working platform is KDE Neon 22.04, User Edition which included KMM 5.1.2. Everything was fine and working perfectly until last week when Neon upgraded to plasma 6. Right after upgrade, KMM 5.1.2 was not being loaded anymore. This created some noise and a bug was reported. A day or two later some packages were upgraded and installed which included KMM 5.1.3. This version was all OK except for account mapping issue which I posted here. During my efforts and thinking about this issue, suddenly I remembered that I had some “Back-ups” of my KMM 5.1.2. with all accounts mapped already.So, I restored the latest back-up,lo and behold, there it was. All my accounts were already mapped and ready as they were before upgrade to Plasma 6. But the mapping issue still remains with KMM version 5.1.3 as of today.
Thank you for your suggestions and replies!

I used OFX backend!
Thank you!

Snap package most likely was KMM 5.1.2 which works fine and maps well.

I can’t think of a reason 5.1.2 would work but not 5.1.3. However, neon has has several issues recently with KMyMoney, because of dependencies and changing package names between KDE5 and KDE6. I just added the “neon” tag - hopefully someone from that team might take a look and see if there is any packaging change that might help.

Also, can you run kmymoney from command line, and look through the output to see if there are any relevant error messages. Another thing would be to enable OFX logging (Settings/Configure KMyMoney) General page, Support Tab. That should create a file “ofxlog.txt” in the specified folder. Be careful with that file, as it does contain plain text account numbers and passwords, so alter them first if you are going to post anything from that file.

Hi, I run the KMM in konsole. It printed about two full pages of stuff about loading the requirements such as plugins and other stuff. I went thru the entire listing all seemed to me OK. The only unusual thing i came upon is a line of fail loading in the following listing :

[quote]Attempt to load the “kmymoneyepTdhH” Python module from “/tmp”
The dependency ‘sys’ Python module loaded successfully
The ‘path’ Python variable loaded successfully
“kmymoneyepTdhH” Python module failed to load
Traceback (most recent call last):
File “/tmp/”, line 9, in
from woob.core import Woob
ModuleNotFoundError: No module named ‘woob’
Plugins: woob loaded
Loading “/usr/lib/x86_64-linux-gnu/qt5/plugins/kmymoney/”
Plugins: xmlstorage loaded

Those messages are harmless. The woob (web out of browser, which is just another way KMyMoney can download financial data) plugin requires python, and the search for the plugin at startup is more verbose that for other plugins.

Did you look at the console output and ofxlog.txt when trying to map your online account?