Kmoney currency udpates not working

I have problems updating currency rates at the moment.
Everytime I try to update any curency pair i will get error message like (of course currencies changes)
"Fetching URL Australian Dollar to Euro - AUD to EUR exchange rate - Find the best Australia to Europe currency transfer
Identifier found: ‘AUD/EUR’
Date found: ‘ke heinäk. 19 2023’
Unable to update price for AUD > EUR (no price or no date)

This problem has been up no at least 2 days. If I copy the url, it will open the page perfectly fine. Any help how could I fix the issue
(win 11, kmymoney latest build (same problem with both master and stable)

Change the regex for the price to


which worked for me.

Thanks, this made the magic

Today I tried this but the fix failed.

Anything else I should change?

I have solved the problem by removing the Regex for Date. Seems to work fine now.

1 Like

The regex for date needs to be:

name="date_input" class="ip_ondate" value="(\d{4}-\d{2}-\d{2})"

and the date format


i have the same problem with KMM currency. the EUR/USD values are updated regularly for all dates prior to August 05, 2023. for all subsequent dates, the system replies “Unable to update the price for USD > EUR (no price or date)”. I tried the solutions proposed here but to no avail. the update is set up like this:
url Exchange Rates - Currency Converter - Foreign Currency Rates - Money Transfer Services Comparison
identifier Exchange Rates - Currency Converter - Foreign Currency Rates - Money Transfer Services Comparison
price 1\s[^=]+\s=<br\s/>\s([^\s]+)
data updated\s\d+:\d+:\d+(\w+)\s+(\d{1,2}/\d{2}/\d{4})
date format %d/%m/%y

The identifier is not important here (and its setting probably wrong, but that does not hurt). Please set Price, Date and Date Format of the KMyMoney Currency entry to the values shown in previous messages of this thread.

Price: Today\\s+=\\s+([^<]+)
Date: name="date_input" class="ip_ondate" value="(\d{4}-\d{2}-\d{2})"
Date Format: %y/%m/%d
Skip HTML stripping: :heavy_check_mark: (checked)

(Image taken from latest development version)

thank you for your interest. I tried to set the variables as from you but the error remains.
KMM 5.1.2 - Linux Mint 21.1

Looking at your screenshots (thanks for posting) I spot a difference in the Formato data field: the final d is missing in yours. Does it make a difference it you add it? Also, can you clear the URL in the field Identificatore. It does not make sense.

you are right, sorry for the mistake. unfortunately, even if I fix it, the problem remains. is it possible, for currencies, to set up another update service as it is possible for stocks? thanks again

Sure you can do that, simply change the settings including the URL. It needs to be that entry (KMyMoney Currency) though.

Note: You can simply paste multiple screenshots into the post, no need to add a separate post for each screenshot.

I tried to replace the Stooq Currency references and details on KMyMoney Currency.
no result, usual error.
I also tried uninstalling and reinstalling KMM (desperation :slight_smile: to no avail.
the strange thing is that the update for august 4th and previous dates is successful the one for august 5th and following goes wrong. mystery.
as a new user I can only paste one screenshot per post.
thanks always

The date format should be %y-%m-%d instead of %y/%m/%d to match the regexp (\d{4}-\d{2}-\d{2})

1 Like

This works, I lost half an hour because of failing to see the “Update” button in the UI (it was somehow hidden in a view with a scroll) make sure you press it:

name="date_input" class="ip_ondate" value="(\d{4}-\d{2}-\d{2})"


many thanks guys, now it works.
the error at the end was the use of “/” instead of “-” in the date format.
thanks always

1 Like

Given the exacting detail in these settings I copied the fields from the first replies above but I think they’re taken from the kmymoneyrc config file (where entries in the KMyMoney > Settings > OnlineQuotes Dialogue box end up). However the program seems to amend the Dialogue Box entries when updating kmymoneyrc (adding extra back slashes in the Price: field - for example perhaps as / escapes??) so copy & pasting those lines will not work.

Copy & pasting conet’s settings into the dialog box (including the hyphens in the DateFormat field) worked well for me in KMyMoney Vn 5.1.3-fa1eab719 so thanks to everyone for sharing and solving this problem for me.