KMyMoney and comma under Wayland

Hello,
Yesterday, I began using Wayland for the first time and observed that in KMM the period key on the numeric keypad is not automatically converted into a comma for decimal separation when entering values. Under X11 this period is correctly converted into a comma, but not under Wayland.

Is this a known issue?
Is there a workaround?

Thank you.

On X11 this is handled outside of KMyMoney. Not sure if there is an equivalent setting for Wayland. Here’s the one that controls that for me on X11

Unfortunately that option has no effect.

See 449706 – Keypad decimal separator should respect regional formatting

@nicolasfella thank you!

Running KMyMoney with:

kmymoney -platform xcb

solves the problem.

fabulous

[image]