KMyMoney installation files for MacOS or Windows?

Hello everyone!

I posted this question on reddit, but AutoModerator suggests posting here.

I’m trying to switch back to KMyMoney from GnuCash but can’t find the install files for Windows or MacOS. The official download page only leads to a pipeline page without any (that I can identify) working download links. Can anyone help me locate a working installer for KMyMoney, especially for MacOS?

Thanks for any help!

You’re not alone with this search (see this thread here on the forum.
The first paragraph of the download page may explain, why you may not find anything there.

And for Windows the same applies as for MaOS: In case that someone (who can build the package) is found and responds, I am happy to help out wherever I can.

Thanks, lpwizard. I’m writing because I need two kinds of help:

  1. Most importantly, is there any way to get a production version of KMyMoney for MacOS? Not only does the first paragraph on the download page (for MacOS) say there are no downloads for end users, but also related links to binary-factory lead to pages that give the error message “This site can’t be reached.” Maybe someone should take down all the signs saying there’s a MacOS version.

  2. I tried to find a working copy of KMyMoney, and I’m afraid I really screwed things up. I’d appreciate any help on fixing things. Here’s what I did:

I first tried to install KMyMoney by using Homebrew, as described at homebrew-kde webpage. But since I got there from the KMyMoney website, I didn’t realize the Homebrew instructions were generic for KDE rather than specifically KMyMoney. So, first I followed the instructions for installing kf5-attica, thinking “attica” was the name for a release of KMyMoney. When this didn’t work, I followed the instructions for installing the bundle, still assuming I was on a page devoted solely to KMyMoney and the bundle included related packages that KMyMoney needed to work. Boy, was I wrong! About a terabyte later, I must have downloaded everything KDE for a Mac, but still no KMyMoney. Alright, I’m ready to admit defeat, but can someone give me some guidance on how to clean up my mess and get all that unnecessary stuff off my system?

Thanks for any help.

Wow, this does not sound too well.

  1. Generating installable packages (both for stable and development versions) recently moved from the old binary factory to the new Gitlab based CI/CD system. During the last week or so, things have changed again in that arena which now allows a permanent download of installable packages. The KMyMoney web-site needs to be adjusted to that though.

This has not been done for two reasons: lack of time and some builds (among them the ones for MacOS) are still failling. We are working on fixing this, but the failures are not always on the KMyMoney side but on its dependencies.

  1. I am not in a position to provide guidance here. Maybe someone with more knowledge about the MacOS ecosystem can chime in.

A little update: with some help from @jlskuz and others, we were able to get the builds for MacOS working again. One is still failing, though. Please see the KMyMoney MacOS download page which has also been updated to contain links to the new locations of the dmg packages.

And while we’re at it: the Windows download page also received an update.


Hmm. According to that page (KMyMoney MacOS download page), it (still) says:

Stable version (x86_64)

Unfortunately, the MacOS build for the stable x86_64 version of KMyMoney on the KDE CI/CD infrastructure is currently broken. We are looking for an experienced MacOS developer to help us fixing the issue. Please contact us at if you can help out.

And no “links to the new locations of the dmg packages.”

Well, what do you think should be done if there is nothing to link to (yet)?

Thanks for the updates. I have had no problems downloading the available versions for Mac. However, on an M1-mac I cannot run the app using anyone of the available (modification date: 2024-03-12) versions. I get the following error message: “kmymoney” is damaged and can’t be opened. You should move it to the Bin.

Any idea what could be wrong?

1 Like

Unfortunately, not me. This is something people with more knowledge about MacOS packaging and maybe involved with KDE’s CI/CD system may take a look at.

Knowing nothing about Macs, I wonder if it might be due to the M1. Do you know if other application executable files run equally well on classic and M1 Macs, or do they need to be differently compiled?

Thanks for the replies! I’m inclined to believe this issue isn’t related to the M1 chip. I haven’t encountered this problem before, and when I installed KMyMoney around 9 months ago, everything went smoothly. Additionally, the availability of both ARM and x86_64 downloadable versions on the KMyMoney macOS page suggests that the ARM version, at the very least, should be compatible.

Can you confirm that this version does work with a legacy Mac? If it works there but not on an M1, I’m stumped. If it doesn’t work there either, then it’s likely that there are more issues to fix with building the Mac version on the new build system.

I have the same problem with an iMac-M3 and the stable version kmymoney-5.1-3138-macos-clang-arm64.dmg. I use version 5.1-1270 (Intel) on this Mac without problems thanks to Rosetta.
Apple Support was unable to help me and it doesn’t appear to be a security/access issue.

Thanks for the information! Then, at least ARM-Macs seem to be affected. Unfortunately I have no access to a legacy Mac at the moment and thus cannot confirm whether the new version works on intel Macs.

Hi everyone,

I have an old x86 version (should be a Dev version of 6 months ago) perfectly working on an M3 MacBook.
Today I’ve downloaded both x86 and ARM, Stable or Dev and neither starts reporting application broken.

Any suggestion?

Is the version available via winget not working either? I didn’t like it, so I’m still using the linux version in a VM.

Apologies in advance for inevitable reiteration of what has been said before.
Clearly there were some transition issues as the old method of distributing packages went offline and this new download page was built. The OP’s specific issue has technically been resolved, but other issues remain.

You see, none of the Mac installation packages are usable. They result the “app is damaged” error, described earlier.
This issue is unlikely to be one related to the “transition” to Apple Silicon, particularly considering the package was built for Apple Silicon. Plus, this transitional period has been unbelievably smooth, and is all but complete. Regardless, for thoroughness, I use a MacBook Air with M2.

Would it be possible, until this is sorted, for someone to dig up the last working version that had been available on Binary Factory / Jenkins / etc? I was using 5.1.1840 until I overwrote it with this new version. I attempted to revert, but strange issues linger. This situation is entirely on me: I did not proceed carefully with the upgrade!

My hope is that the issues are resolved with the new version so we of the Mac persuasion may enjoy it too, but until then, any Mac user who goes looking for KMyMoney will currently find no official solution.

My thanks to those involved!


I have the same problem with Mac version of kmymoney. The latest versions which are available for download give the same error as above. I am currently using version 5.1.3-33a66be8aon on MacMini with M1 macOS Ventura and it is running fine. Unfortunately I do not have the installation package for it anywhere but I found a little bit older version Version 5.1.2-070754227 installation package from my backups, file name kmymoney-5.1-1082-macos-64-clang.dmg. It is for Intel hw based macs but I installed it and seems to work ok (not tested thoroughly) with my M1 MacMini. Only thing I had to do to get it running was to allow it to run from system settings. If somebody wants to try it I can share it (of course with no guarantees whatsoever).


Hello everyone! It seems I’ve found a temporary solution that allows running the latest packages (at least the ARM ones). The following commands help bypass the damaged package notification (you need to paste them into the terminal app):
xattr -p /Applications/
xattr -d -r /Applications/

Alternatively, if you don’t trust the above, you can Google using the following keywords: bug 487506

1 Like

Those commands and the mention of suggest that maybe this is a false positive on some malware scan. If someone can tell us exactly what those two xattr command (-p and -d) do, we might make a better guess. However, it might also be good if someone knows how to report a false positive to Apple.