Kmymoney won't run

I’ve downloaded the kmymoney-5.1-1941-windows-cl-msvc2019-x86_64.exe installer and run it on my windows 11 x64 machine. When I try to run the kmymoney.exe application the splash screen shows up for less than a second, then nothing else happens. I’ve searched the task manager and there isn’t any sign of anything with kde or kmymoney in the application name or publisher name running.

If it is a bug I will report it but I was wondering if perhaps there could be something else interfering that is not a problem with the application. Any suggestions or help would be appreciated. This is my first time trying to use kmymoney and it’s very appealing to me compared to the other options so I would really like to get this to work.

Edit - I’ve downloaded the 7z and tried to run and came up with the same issue. Splash screen pops up for a moment then nothing.

Does this still occur with the latest version?
I would check the logs for KMyMoney to see if it crashed or another issue caused it to halt.

It still crashes with 1942. I can’t find any logs, do you know what the file path might look like?

I’ve tried running from cmd and this was the result: C:\Program Files\KMyMoney\bin>kmymoney -nC:\Program Files\KMyMoney\bin>WebCo -

I first thought this was likely to be a problem that had previously been reported and fixed. However, the console output looks different to me. (There is not likely any other log file.) The error looks like it is missing a python related file, and it happens when trying to load the Woob plugin. Do you have Woob installed, by any chance? Whether or not, I think for now, you just have to wait for one of the developers to look into the build system to see if anything has changed. Unfortunately, I don’t think there is anything you can do on your system to make it work.

I don’t have woob or even know what it is. Should I file a bug report? Do you know of an older version number that would likely be working?

I downloaded the zip on my work computer and ran it and it appeared to run just fine, so it’s specific to my home machine.

I’m looking again at the cmd output, and I’m now wondering if there is something wrong with your python installation. Do you actually have python installed? Woob (web out of browser, see is a python based program for interacting with web sites without using a browser. KMyMoney has a plugin to let you use woob to access certain banks (that list depends on woob, not KMyMoney.) When KMyMoney starts up, as part of loading all available plugins, it tries to check whether woob is also installed. This check is what appears to be failing. If Python is not installed, woob can’t be either, so the check should fail cleanly. The same should happen if Python is installed but woob is not. As I read the cmd output, KMyMoney has successfully called Python, which is failing because it can’t find it’s own “encoding” module. This suggests a problem with your python installation. Can you try reinstalling Python?

Uninstalled python and reinstalled. Uninstalled and reinstalled Kmymoney. Restarted my computer. Same result, splash screen shows for a sec then nothing. New error though. kmymoney python error -

The error looks the same to me. Does this post (python - Pipenv could not find platform independent libraries <prefix> - Stack Overflow) help any. Specifically, are you sure you have only one Python installed? If you do have more than one, try deleting one of them.

I ended up resetting my computer, it needed to happen anyways for various unrelated reasons. When I installed kmymoney again it worked just fine.