Known Bug/Issue? Background application hotkey for 1Password not working (kde 6.0.3 sddm wayland)

Hey there folks! I’m using kde 5.x on X (default manjaro kde installation) as my point of reference where this functionality worked as expected. That is to say, while having applications like firefox open I could activate a hotkey for 1password if it was minimized or otherwise unfocused.

I’m having an issue in my arch installation on my laptop where hotkeys for background applications don’t seem to work. KDE 6.0.3, sddm, wayland, unsure of what else may be helpful. There’s an interesting secondary behavior where the hotkey will work for other electron applications (ie. I can use 1password hotkeys while ms-teams or clickup are open and clickup hotkeys while 1password or ms-teams is open). None of the electron app hotkeys work while non-electron apps are open such as firefox or thunderbird.

I kind of figure this is a known wayland issue but I do not believe I have found it on the internets after searching for 30m or so. I’d make a bug report in KDE but I’m not positive it is a bug with KDE or wayland or possibly something else in my setup is missing.

I’ll open a bug if no one knows about it, just wanting to make sure this is being tracked somewhere as it is a really helpful feature for productivity to me. Considering rolling back to KDE 5 or at least X.

Let me know, thanks, Josh

The problem is with the 1Password application and Wayland - it does not support Wayland and runs as an XWayland application.

XWayland applications use global shortcuts by just listening to the X11 input event bus - where they see all keyboard input - until they see the shortcut they are looking for, but this is not allowed on Wayland, so it doesn’t work.

Ideally 1Password would implement support for Wayland, and specifically integrate the Wayland global shortcuts portal and that would be that. But until they do that - 1Password have a workaround documented on their website here: 1Password Shortcuts on Wayland — 1Password Community .

The documentation only shows how to set the “custom global shortcut” on GNOME, but the process is similar on Plasma:

  1. Open the System SettingsShortcuts editor.
  2. Click Add New
  3. Select Command or Script
  4. In the dialog that opens, enter the 1password “quick access” command: 1password --quick-access
  5. Click Add
  6. It will create the new command under the “Commands” section - click it and set your global shortcut key.
1 Like

This isn’t exactly true, see the “Legacy X11 App Support” KCM where you can enable a specific level of keystroke reading:


Wonderful! Both of these work but I hit solution on the second one that uses a kde setting to enable legacy hotkey stuff. I love that this is implemented and I appreciate the somewhat-more-secure option of allowing keystrokes when ctrl/alt/shift are pressed.

While I haven’t yet implemented anything else with the hotkey to run a command I will probably do something like this at some point. Glad to see how easy it is!

Excited to see how this type of cross-app permissions ends up implemented presuming it gets to kde-wayland at some point in the future. I’m hoping they do it justice and make it a bit like, or better than, macos app permissions.