Konqueror opens sub-directories in Dolphin

I am using Konqueror as a file manager.

If I wish to go into a sub-directory by double-clicking with a mouse or pressing Enter with a keyboard, the target sub-directory opens with Dolphin.

How can I configure sub-directories I click on in Konqueror to stay within Konqueror?

click on the desktop and type “file associations”, then go to the settings page from search results.

there you can specify what apps to use for what items and the order they will appear in the “open with…” context menu.

for folders, go to inode type and select directory, you should be able to add konqueror to the list if you have it installed.

Thank you for the reply skyfishgoo.

I followed your suggestion but it did not address the issue for Konqueror was already in the list of apps. Then I discovered this solution:

  1. From Konqueror or Dolphin right-click on a directory and select Properties
  2. From the dialogue find Open With
    Click ‘Change…’
  3. One should see a dialogue for File type inode/directory
    Dolphin and Konqueror are each present in Application Preferences but sub-directories chosen in Konqueror open in Dolphin
  4. Click tab marked Embedding
    In that tab I found the option ‘Show in separate viewer’ set. How it became set that way, I do not know.
  5. Choose the first option: ‘Show file in embedded viewer’

    Click ‘Apply’, ‘OK’

Sub-directories chosen in either Dolphin or Konqueror should now open in the application you are working in.

1 Like