Konsole misbehaving

I installed the latest ISO for ArcoLinux and have had nothing but issue with Konsole.

From my thread on his forums:
https://arcolinuxforum.com/viewtopic.php?t=3704

I noticed that when Konsole is launched whatever was in it when I closed it is in it when I reopen it making me have to clear it. Also rather I click on Konsole to open another instance or click open new tab I get neither the new window or new tab.

I am out of ideas, any suggestions would be greatly appreciated.

Do you get the same issues if you create a new user account?
EDIT
Tried to watch video of what occurs and no longer available, I have not experienced this or seen anything similar as Eric mentions over on the arcolinux forum

1 Like

Try the 'Half-Split` troubleshooting idea.

Open Dolphin ~
Create a new folder '~/CRUDDYSTUFF
Press F3, open that folder on the right.
On the left, select all - and deselect that folder then press ShiftF6 to move all the ‘CRUD’.

Log out, Log in, Test again.

If problem clear, then select HALF the contents of CRUD, and ShiftF6 it back.

Log out, Log in, Test again.

If the problem re-emerges, then look at the last set of stuff you imported (First can move it back, isolating it to to yet another folder in the CRUD folder, then import everything else - test again to be sure).

If the problem is just Konsole, did you try resetting the Konsole configuration by removing ~/.config/konsolerc (when Konsole is not running, of course)?

2 Likes

As I always try to mention with this is to rename not delete that way you can easily restore if needed and the suggestion doesn’t work

3 Likes

Which is exactly what I did. The only difference in letting Konsole recreate that file was theme and font were restored to default but the behaviors are still there. As for the CRUDDYSTUFF idea I’m passing on that.

Yes same with new profile.

Konsole does not save/restore previous sessions.

What is tmux client ?
Do you see this same behavior in other terminals ?

I’m not installing other terminals just to test.

@Smokey here’s the video.

@anon20537621 same questions

What is tmux client I can see in the Konsole titlebar ?
How have you configured it and see my last comments on [OPEN] Konsole opens to last state it was in when closed - ArcoLinuXL -XS -D -B Forum

I honestly couldn’t tell you, cause all I do is install the OS, reboot, check and do updates, reboot, tweak my settings, and then install and setup the rest of my applications.

As for Konsole after all that is done I install and setup zshforhumans, edit my profile to use ZSH, change the theme, edit the fonts if needed, set scrolling to 1 million lines and that is it.

I’m assuming that’s the post you’re referring to?

This is the first time I am seeing this in Konsole.
It looks like your session is being cached somewhere and is being restored even though you have closed the Konsole instance.
Even a new tab results in restoring a previous session.
Konsole does not have this feature out of the box.

  • What does your profile settings inside Konsole look like - any special configuration (excluding any zsh tweaks) in place ?
  • Have you tried creating a test user which would ultimately give you a vanilla Konsole to use; thus giving more insight into whether a config change is causing this behavior ?
  • Do you use Tmux? If yes how are you detaching and re-attaching (do you use any keybinding, or is this baked into the tmux configuration) previous sessions, and did this behavior change after updating to Plasma 6 ?

I’m going to create a new profile now. I did remember installing Alacritty to test, and just did that. When I launch it it opens and Konsole closes and if I relaunch Konsole Alacritty closes.

EDIT:

I just created a new test profile and it does the exact same thing.

I don’t have Tmux installed to test, but it looks like you have it installed as part of a dependency of various other packages. So removing it is going to be difficult.

Tmux

“terminal multiplexer: it enables a number of terminals (or windows), each running a separate program, to be created, accessed, and controlled from a single screen. tmux may be detached from a screen and continue running in the background, then later reattached.”

Do you have a tmux config file in place inside ~/.tmux.conf

Have you tried this tmux - ArchWiki

Edit > Also check your ~/.zshrc file for anything relevant to tmux

2 Likes

YES YES YES you da man!!!

Checked .zzhrc and commented out the line with tmux in it, launched Konsole and empty except for the expected ZSH prompt. Tested running Tograde and was able to scroll. Got a new tab when I clicked New Tan. Got a second window when I clicked Konsole’s icon on my dock, and when I launched Alacritty it opened without closing out Konsole. Thanks very much appreciated.

1 Like

The “zshforhumans” setup asks if you want to use tmux on every shell, which you can say “no” to. It would probably have been a better idea for “zshforhumans” to actually treat its users as humans and explain what it means - it means that it never forgets what you did in your console, and all new shells connect to the same single terminal: you need to use the tmux commands (keyboard shortcuts) to create subshells in tabs and windows inside tmux.

For people who aren’t familiar with terminal multiplexers (tmux is not the only one) this would be very confusing and I think this is a bad default - the fact that “zshforhumans” gives you the option to not have that is good, but the fact that they don’t explain what it means and it is still the default - is bad.

The other problem I see in your screencasts is that when you press “new tab”, you get a refresh and nothing else happens. I’m guessing that a new tab was created but its shell was immediately connected to the same tmux sessions - so you don’t see that anything actually did happen, but I would have expected to see the tab bar showing another tab was created. The problem is probably that your tab bar is hidden for some reason (it is not the default). I suggest going to Settings → Configure Konsole → Tab Bar / Splitters → Appearance then in “Show” change it to “When needed” or “always” (the default is supposed to be “When needed”).