Konsole not restored after logout if program was running

I have my desktop session set to restore the apps open on last logout. It’s mostly working, except konsoles will not be restored if a program was running in them. Is there any setting I need to toggle or anything I can do?

It’s an issue when I have several tabs open in a single konsole window and none restore if I happen to leave e.g. a text editor open on one. (I believe in previous KDE versions the konsole would restore but the program would no longer be running, which seems to be the most sensible behavior.)k

I’m on KDE 5.27.8

Is there a reason you used the baloo tag? Or was that by mistake?

This was a mistake; thank you for pointing it out. Edited.

konsoles always just come back up after restart with an empty screen and just the prompt showing… the history is still there tho.

htop or watch commands that were running at the time are halted… as far as i know it’s always been like this.

It used to be that the program was halted, but that konsole with any other open tabs was restored. e.g. if I had a konsole with two tabs

Tab 1: htop
Tab 2: folder

then I’d get

Tab 1: folder before htop was started
Tab 2: folder

I like that behavior and think it makes sense. However, I currently get nothing: i.e. such a konsole window is currently not restored at all.

haven’t done much with tabs, but i just tried one with 3 tabs
watch -n 0.1 sensors ;

and they all come back halted with just the prompt

maybe there’s a way to launch a bash script that will keep a text window alive thru a reboot, but i’m not that good a scripts.

Are you also on KDE 5.27.8? I have another system with KDE 5.26 and I don’t have this issue, so I thought I was missing some setting in the new KDE.

PS: The behavior you just described is the behavior I want. But when I test it the konsole disappears (i.e. I don’t get anything restored).

i’m on 5.27 now, but i’m pretty sure it worked the same when i was on 5.25.

kubuntu 22.04 with backports enabled.

are you having any other issues with suspend/resume that might indicate an acpi disconnect… i ended up doing quite a bit of work to get suspend/resume to work properly, esp with my nvidia card.

or it’s just how your distro set things up for plasma and kubuntu went a different way.

Are you running Wayland or X11?

I’m running X11 with Arch.

Suspend seems to be working as intended. This is a new install and it’s the first time that I’m having this issue, so I thought it might be the version. (My previous install was up to 5.26, as I mentioned, and worked the same as what you describe.)

add another piece to your puzzle hobbie

good luck

one last thing, when i go to close the window with multiple tabs open i get a confirming dialog asking if i just want to close one tab or the whole window.

no idea if it’s related, but just in case it matters.