Krename not working on plasma 6


I am on an up to date Tuxedo OS (on generic hardware), and I updated to Plasma 6 just yesterday.
It mostly works OK, but KRename no longer works:

Krename starts, but on the source file selection screen no files are listed in the right-hand panel, irrespective of what drive or folder I select in the left-hand panel. So I cannot rename anything.
Any ideas on what I may be doing wrong, or any solutions/workarounds?

Edit: It does this both in x11 and in Wayland,


A bit unsure of what you are trying to explain, maybe a screenshot would help

What happens if you select the files in Dolphin and open with Krename (this is how I normally use it).
I just tested on my system opening files and don’t seem to have an issue but I am using a different distro
Final thought have you tried this with a new user to see if the same issue occurs there?

The sequence of operations is this:
Open Krename from the Launcher
click on Add files on the right, the add files and folders dialog opens
on the left pane you have folder names and on the right the file names in the selected folder should be visible.
In my screenshot I selected the Downloads folder, and I should see several file names on the right, but I see nothing.

I did not try as a different user, I do not have one set up on this machine.

I did try to uninstall and reinstall krename, but there is no difference.
I tried opening the files directly from dolphin (with the Advanced rename options), but I cannot select the Find and replace function (it is greyed out), which is what I need.

Many Qt apps like krename, qtpass, qgit, okteta, labplot, krusader, kshutdown, kronometer, krita, krdc, kompare, k3b, kaffeine, ghostwriter, firetools… are still using Qt5.

For krename, make sure you have the following packages installed: (names may be different depending on your distro)


I tried to install qt5 following some instructions I found on the web, and it looked like it installed something, but krename still does not work.

I do not know how to check if I have the indicated packages

I would suggest to run krename in terminal (Konsole) to get more info on what is going on.

Hopefully that could help to determine why you are having this problem, but other than that it might not say anything.

This is krename launched from the console. It still does not show any filename in the right-hand panel.

I do not understand any of its output in the console

Hmm no idea what is going on but you can easily create/remove a user in the system settings

Looks like a bug, what I could find is that other people had same issue in KMyMoney app, but I could not find a solution to this. I guess it’s not a problem with krename, but with kde frameworks kio package.

Here is bug report on this sort of issue:

You could report this issue to KDE Bugtracker, and/or report it to your distibution, as it also could be some sort of packaging issue

Just to wrap up this discussion, I ended up reinstalling Tuxedo from scratch (for other reasons), and Krename still does this. So I just gave up on it, I found some replacement (filerenamer) which is not perfect, because it does not save complex manipulations. Oh well, the search goes on, I suppose.

Thanks for the attention.

@medin is correct. This is a packaging issue. The missing package is called kio.

sudo apt-get install kio and it works again, I just tried it in a VM

Thanks! It worked for me too! :grin: :smile:

Glad it works for you, I filed a bug for tuxedo OS, this should properly resolved eventually.

1 Like