Krunner hides on win+space

I don’t know when it started exactly, but now my krunner hides while I trying to change keyboard layout by win+space. It is just my local problem, or new behavior for krunner? Can anybody confirm?

By default the shortcut is Alt+Space and Alt+F2, check Shortcuts in System Settings if they are set differently.

All KDE shortcuts are correct.

But, I seem find the problem – it was a ibus-setup. When delete short-cut (win+space from it settings), the issue is disappeared. But I’m not shure.

I use KDE Neon.
Steps to reproduce:

  • ibus-setup started and has a shortcut to change keyboard layout (win+space)
  • kde has the same shortcut to change keyboard layout
  • open krunner, try to change keyboard layout - the krunner clooses

I would guess that ibus on keyboard layout change un-focues KRunner and when it looses focus it hides. I use Ctrl+Alt+K layout change shortcut here (I do not use or run ibus at all), which is set in KDE keyboard layout settings, and it does not hide KRunner here since focus remains on it.