Krusader root and kdesu

I installed the latest version of krusader and tried to go into root mode. It didn’t work, then I searched the internet and it says that I need to install kdesu and add it in the krusader dependencies.
But there are no such line. I thought I was out of my mind and even went into the documentation. There’s a line in there.
kdesu → /usr/bin/kdesu
My one doesn’t have it. Please help.

Well to be more precise, all I want is to be able to run krusader in root mode without errors.

What do you get when you click on the following entry


I am prompted to enter the password, and there are three different windows one after another, although the essence is the same. And of course I’m entering the password correctly each time.

Also if I run root krusader through the console everything works as it should, although it will give a bunch of errors.

So I kinda solved the problem. A bit radically but at least there are no errors and bugs anymore.

sudo pacman -R krusader
sudo pacman -S dolphin
  • You can also install kde-servicemenus-rootactions to get more root actions in Dolphin
    yay -S kde-servicemenus-rootactions


  • There is also kio-admin
    sudo pacman -S kio-admin
    But it has some annoying behaviors.

I tried all the solutions you suggested and unfortunately they didn’t work.

However, I found another one that does work.

Configure Dolphin → Context Menu → Download New services
Search for open dolphin as root then install it.
Then it appears in the context menu to “Open As Root”.

Unfortunately there is no such convenient menu of actions with files as in kde-servicemenus-rootactions but it works.

Search for “Root Actions Servicemenu”

Yeah but unfortunately it still has the same problem as krusader, it says that I’m not entering the root password correctly.

Maybe it’s because when root actions servicemenu’s input doesn’t work, input password window writes “kde SU”
Open dolphin as root writes “policykit1 kde agent” in input window and it works.