Language mix after updating to KDE Plasma 6.1

Hi! I recently updated on my Fedora 40 installation from KDE 6.0 to the brand-new and shining Plasma 6.1 and I like it so far. Except that 6.1 ate my language settings. It is now a mixture of German (my main language) and English. Specifically, things like “Show Panel Configuration” or “Log Out” (on the logout screen) are - well - in English, but should be in German.

I tried re-setting the locale etc. but no effect. Can it be that these strings just don’t have a translation yet, and so they fall back to English?

Probably, but maybe not. Can you share a screenshot of your language settings?

1 Like

Hi, I have the same problem. It appeared after I updated KDE from version 6.0 to 6.1. The system I’m using is CachyOS (an Arch Linux derivative). Where I wrote “OK” is correct, that’s my language, and where I wrote “NO” is not my language. The language I use is Polish, so the format there should be “pl_PL”. The file /etc/sddm.conf is empty, and when I paste this:

[General]
Language=pl_PL

And restart the system, nothing changes.

There is also a language mix when using German. E.g. the context menu on the desktop:

The menu items “Desktop and Wallpaper” and “Display Configuration” where in German in KDE 6.0

or the hints in the font settings

My context menu looks exactly like the screenshot hcastorp posted. My language settings seem ok, see the screenshot.

By the way: Changing the locale and language works, for example switching to English. But if I switch back to German the language mix reappears.

Can you click on “Ändern ….” on the “Sprache” row and paste a screenshot of what it says?

Here it is. Looks correct - “Österreichisches Deutsch” is a version of German, the code is de_AT, I think. This is my first (preferred) language, with standard German and English as fallbacks.

Hello, same problem here since Plasma 6.1. I only have one language set in language settings however I have the environment variables

export LANG="en_US.UTF-8"
export LC_ALL="en_US.UTF-8"
export LANGUAGE="en"

set because I want English output in the terminal. Not sure if this has any impact on Plasma.

Hello everyone, the same problem, but with Russian language. Part of the interface is in Russian, the other in English. There is only one language in the system. Below is a screenshot as an example.

Operating System: openSUSE Tumbleweed 20240704
KDE Plasma Version: 6.1.2
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.2
Kernel Version: 6.9.7-1-default (64-bit)
Graphics Platform: Wayland

It got even worse with some recent package updates. Now the digital clock widget displays the time in US format with AM/PM although my time formatting is set to German (24h).

I also use openSUSE Tumbleweed, by the way.

Maybe caused by your LC_ALL="en_US.UTF-8" ?
At least with my LC_TIME="de_DE.UTF-8" (and everything else as well set to German) while i can confirm the language mix as shown in the screenshots (for German) above the digital clock widget behaves correctly.

KDE / Qt the same (up to date) versions except Arch 6.6.37-1-lts Kernel here.

Maybe caused by your LC_ALL="en_US.UTF-8" ?

Yes, you’re right. Regarding the clock it was related to my LC_ALL. But event with de_DE.UTF-8 there I still have a language mix in Plasma 6.1.

1 Like

Have the same problem with russian language. KDE Neon 6.0 (plasma version - 6.1.2; wayland)