Laptop: System Monitor never gives charge rate >0W: Bug?


after a hardware mod of the laptop mainboard, I noticed that the charging rates in System Monitor are not positive when charging.

I have never checked there before and can’t undo the mainboard mod. Impossible to decide if this is a homemade issue or a real Plasma bug to be reported.

I am suspicious of System Monitor because right now it shows -0.1 W at the same time that upower returns a charge rate >0 W:

$ upower -i `upower -e | grep 'BAT'`  | grep rate 
energy-rate:         0,077 W

Could someone do a quick check on their system?

Here it’s System Monitor 5.26.5; Manjaro; Plasma 5.26.5; KDE Frameworks 5.103.0; Qt 5.15.8; Kernel 6.1.19-1-MANJARO (64-bit); Graphics X11


What mod did you make to your laptop’s hardware? I strongly suspect that these two events are related. :slight_smile:

Another data point would be what the energy page in info center displays.

Sorry for the late reply – lots to do elsewhere.

Still the same after the April Manjaro updates. Versions are now:
System Monitor 5.27.3: Manjaro; Plasma 5.27.3; KDE Frameworks 5.104.0; Qt 5.15.8; Kernel 6.1.22-1-MANJARO (64-bit); Graphics X11.

Of course! – or this would have been fixed aeons ago.

The mainboard mod followed the first (currently only one fully published) HowTo of the Framework fix for what is apparently an Intel snafu. Unfortunately, Framework does not publish detailed schematics (likely to protect supplier intellectual property it was mentioned on their forum, I didn’t bother asking for them).

I’ve tested also with the OSs of two live systems:

ubuntu-22.04-desktop-amd64.iso (not KDE, not Arch based)


Ubuntu (blue: discharging, battery only; red: charging w/AC) labels with “Rate” apparently the total power consumption. “Rate” is always positive and sharply rises when AC is plugged in.

(Ignore the red-blue chaos in the lower right corner – that is the rapid switching between charging and discharging after the charge limit (80%) was reached. Hysteresis could have been set a bit wider, imo, but that is another story and shall be told another time, and to the BIOS guys.)

… to be continued due to new user limitations …

kubuntu-22.04.1-desktop-amd64.iso (KDE, but not on Arch-oid)

Same result as with Manjaro KDE; charging rate negative while discharging and while charging.

Note how the “Charging Rate” drops deep into the negative when AC is plugged in. This would make totally sense if “Charging Rate” were actually the “Negative Total Power Consumption”. (The rightmost part of the curves show the reached max charge state.)

… to be continued due to new user limitations …

Screenshots below, Info Center is on bottom and below System Monitor window.

Note that the time scales are not equal: System Monitor, 900secs; Info Center 1hr. (Why can’t we set times >999secs in System Monitor? Computers can handle more than three digits these days.)

… to be continued due to new user limitations …

… to be continued due to new user limitations …

I’m positive now that the charging rate in System Monitor on this modded Framework Gen11 returns the negative total power consumption.


Too exotic an issue to warrant a bug. I’ll just relabel the diagram in System Monitor.

Happy Holidays, :nest_with_eggs: , and thanks for discussing!