Latest KDE Neon broke my install

August 4 EDIT: asked around the linuxgaming reddit, one user reported this:

Sounds like a distro issue.

Kde 5.27.7- kernel 6.4-Arch Linux and 7900 xtx here, no such problem.

=========== End updates =======================

Title is self-explanatory :unamused:

Using KDE neon user edition ( since 5.10.X ). Latest update towards Plasma 5.27.7 can’t even reach the desktop session, gets stuck on the motherboard logo.

Had to reboot, select recovery mode & now trying to find out a way to fix it.

Thinking about obvious conflictive sources ( since i don’t have any uncommon app installed ) i can think of:

  • I have installed kernel 6.1.0-1017-oem

As for why or if i do really need it… answer is yes, as my GPU is one of the latest 7000 series Radeon ( upgraded on february 2023, working fine since then ) and does need kernel 6.1.x or higher to work properly.

Looking around for fixes found somebody suggesting to do:

ls -1 /etc/apt/preferences.d/

which throws the following result


Not sure if it helps.

Tried rebooting with previous kernel versions with the very same result.

There’s no available updates.

What should i do or try next?

Thanks a zillion in advance.

do you have your /boot on a separate partition and if so how large it?

do you have themes installed?

These ‘oem’ kernels can be very problematic. Do any other kernel choices in Grub boot for you at all?

Ubuntu just today pushed 6.2 kernel upgrades to 22.04, so you should see this if you are able to update from recovery mode if you can’t get to a desktop or TTY.

1 Like

why do we keep getting these if they don’t work?

shouldn’t the LTS be spared from this kind of thing?

last time i had to revert back to -46-generic to get my system to boot and then wait for these oem and hwe kernels to disappear from my list of updates before i could let it proceed.

and now it’s happening again.

boot to a recovery mode of your previous kernel and do booth the clean and the dpkg options, then try to reboot to that kernel version… you should see the updates now pending again.

do NOT do the updates… or you will be right back where you started.

instead wait… for a few days if necessary… for the pending list of update to get sorted.

The OP installed a non-standard and specialized kernel, to support their hardware.
I have seen some *buntu users getting some of these ‘oem’, ‘nvidia’ and ‘lowlatency’ kernels pulled in by some sort of bug in an Nvidia package, but it isn’t universal. That isn’t the case here, since the OP is not using Nvidia, and installed this specific kernel on purpose.

In Ubuntu, the ‘hwe’ is the official kernel track on desktop LTS. The hwe packages are meta-packages that just define a set of dependencies, currently the 6.2 kernel as of today.

Thanks for your help.

  1. No, Neon is installed on a dedicated 0,5tb nvme drive. /boot is 300mb with not even 7mb used from what i can see
  2. No. It’s been a long time since i try to keep my main machine as “standard” as possible.

I do modify some things ( breeze-dark instead of light, buttons/panels arrangement for Dolphin, desktop panel up-center in dock-looking mode ), but try to keep everything within KDE-Ecosystem & favor QT apps if i can adapt to 'em instead of GTK ones. Conscious choice, aiming - precisely - for stability … as i’m already aware how conflictive it can be the moment you add more third-party stuff.

As claydoh already stated: i had to install this OEM kernel intentionally as HWE or any other kernel version didn’t work with the new AMD gpus, they have been made linux-compatible since day one… however that was for 6.1.x kernel version & higher… 22.04 LTS version wasn’t there and nothing was ported yet by then.

You’re absolutely right. While on recovery mode checked for updates and the new 6.2 kernel popped up, updated my system, tried to boot from 6.2… it remains stuck on the motherboard logo.

Can’t say i’m 100% sure but looks like the issue isn’t entirely tied to the kernel version as i tried booting with previous 6.1.X kernel versions ( before this 6.2 update ) and none of 'em worked… even though they’ve been working fine ( very stable ) since february.

Just noticed some new packages now but they all seem GTK related, just updated & about to reboot but i’d be shocked if this changes anything.

What is this pin for? That is not common, and does involve third party mesa video driver packages.
I know it is named as ‘.save’, but I am not sure that this disables the file at all here.

I have used this PPA myself in the past,. I stopped as there were updates almost daily, and on rare occasion something would break. Mainly it was the daily video driver updates that annoyed me, needing daily reboots. I use a different PPA, which doesn’t update quite so much. In any case, I never needed to pin packages from it.

When booting hangs, can you hit to see if anything useful shows in the terminal output there?

Already on recovery mode … otherwise wouldn’t be able to reach the desktop session.

Not entirely sure what do you mean by the “clean” option ( i do remember executing autoremove though ), i did run dpkg as suggested in the terminal, however booting from previous working kernels didn’t change a thing.

If you can make a short/bullet point list of steps to follow i can try again.

Thanks a lot for your time & patience.

by clean i meant the autoremove option but it sounds like your issue is different than what i experienced with my /boot partition filling up all these kernel images i don’t need, so i’m afraid i’m no help.

What is is for… honestly i have no idea as i did nothing besides install oibaf’s repo.

It’s also related to this brand new AMD gpu which works better with 6.1.x or newer kernels and since it’s so “new” it benefits for such ( you’re spot on ) “aggressive” update cycle… which certainly push updates on a daily - or almost daily - basis.

When booting hangs, can you hit to see if anything useful shows in the terminal output there?

Unfortunately no. It gets stuck with the motherboard logo on it, sometimes there’s some visual corruption ( pixellated lines here & there ) but wont’ display anything else.

When i updated to kernel 6.2 today & rebooted i’m almost sure there’s tasks being executed altough not displayed while all i see is the motherboard logo… which i deduct from the fact that i 1) updated on failsafe mode to kernel 6.2 , 2) rebooted , 3) the system got stuck on the motherboard logo but after a short while rebooted on its own… same as when it applies updates then reboot again… 4) after that automatic reboot kernel 6.2 showed on the list, so certainly it applied updates, rebooted… only it doesn’t show anything

Don’t worry too much about it; was under the impression this is the usual hardware compatibility issue that needs further fixes/updates… that simply aren’t available yet.

What does the file contain? I wonder if it is blocking packages?

As to PPAs, I use Kisak’s PPA. oibaf uses git pulls, hence the daily updates. Which is not necessarily better, or worse tbh.
This one is also a popular, and has a less frenetic pace.

I have been using Kisak’s for a number of years, though I currently only have an RX 6650. The bump to the latest offical-ish Mesa has helped AMD cards quite a bit, I don’t think you necessarily need to have a constantly bleeding edge Mesa at this point now.

thanks for that clarification, yes my issue was with the NVIDIA kernels and i just remember hwe being one of the variants that floated by during that mess, so i panicked when i saw it again (shades of ptsd).

if i’m understanding this right, the leading kernel version is 6.2 and this hwe package is the blue print for all the dependencies needed to get there, however my 22.04 is still back on 5.19 because it’s the LTS release.

so if i let this hwe update proceed with its headers and such i will still be on -50-generic for my boot kernel image, correct?

the confusing part for me is i see in the list linux-image-6.2.0-26-generic and it’s size is 0 B.

so does that mean it’s being “held back” in apt terms?

Hmmm… definitely have a point there, now ( which translates to “since today” ) 6.2 is officially here i no longer should be coexisting with this OEM kernel + daily Mesa updates.

Going to check if i can fix this current mess by disabling Oibaf’s & adding Kisak’s ( thanks A TON for the tip by the way, Kisak’s description fits my needs better, i don’t even play games on Linux, just had Oibaf’s because it finally allowed my GPU to work as it should along that OEM kernel otherwise wouldn’t use it ).

Will update over here whether i manage to fix it … or not ( hopefully the former ).

I think the 0b is an an error/bug, or heavy rounding.

LTS see regular kernel upgrades though its life. Starting with 5.15, then to 5.19, and now 6.2. Actually, the OG kernel is the 5.15, so older installs might still have 5.15 as well as the latest HWE. (to add confusion HWE kernels do not replace the OG kernel track, the co-exist)

As *buntu do keep three kernel versions at any time, you will start out having both the 6.2 and one or two 5.19 kernels, until newer security fixes in 6.2 replace them, and older kernels are autoremoved. So eventually, the 6.2 will “push out” the previous HWE (5.19).

You will need to ppa-purge oibaf first, reboot to be safe, then add Kisak or another PPA
And remove that pin file, too, just in case.

Just disabling a PPA might not work well here. You will wan to go back to stock here first.

I’ll trade ya GPU’s :stuck_out_tongue_winking_eye:
I do game on Linux, exclusively.