LibreOffice Flatpak fails to provide a menu when using KDE Global Menu

Hey guys,

I have been using KDE global menu pretty much since I started seriously using KDE. I run KDE on a Fedora derivative called Ultramarine (which just helps take some of the pain points out of running Fedora like RPM-Fusion repos, and undoing some of Fedora’s decisions that they make purely on Legal basis such as the recent change to the media decoder on AMD GPUs). Well, if you aren’t already aware, RedHat has stopped maintaining the LibreOffice RPM. This isn’t a big deal to me. There are two options, I can install the RPM from like a Windows user (ew), or I can install the Flatpak version using the Flathub repo (and not the Fedora one). The problem, however, is that I am unable to get the LO Flatpak to work with the KDE global menu. A good workaround for this is to used tabbed mode, but I prefer the classic mode in LO as it saves a lot of screen real estate. Everywhere online says to add a Session Bus talk, com.canonical.AppMenu.registrar, but that doesn’t work for me on the LO Flatpak. Does anyone here at least have the ability to point me in the right direction for trouble shooting this issue? Thanks.