Login screen does not respect Plasma global scaling

Hi. I am using a HiDPI screen, so I scaled Plasma to 250%. In the past, after clicking “Apply Plasma Settings…”, the global scaling option can be applied to the login screen.

However, after upgrading to KDE 6, this doesn’t work anymore. The login screen didn’t scale after applying Plasma Settings.

Is this a bug? How to fix this?

PS. I am using SDDM. I tried to switch from Wayland to X11, but the global scaling option cannot be applied to the login screen either.

This is a known bug at the moment: 467039 – With SDDM using Wayland, syncing settings does not send along the correct scaling as it does with X11

It’s being investigated and should be fixed soon-ish.

1 Like

Thank you! I didn’t know there was a bug report. I will search the bugtracker first next time :smile: