Looking for a workaround for Neon Live nomodeset stuck into an infinite loop

Hello, this is my first post!
I’m just a lazy, long time Micro$oft Windows user trying to find a new home!

I would like to install KDE Neon on a machine with Nvidia 40xx GPU and no CPU integrated graphics…

I was able to run Neon on other machines, but in this one I’m forced to use the safe graphics mode option because of the GPU…

The problem is that safe graphics mode option seems broken at the moment for the Live ISO (neon-user-20240229-0716.iso). I tried it in many different machines and every one always get stuck in the exactly same infinite loop if tried to launch it in safe graphics mode.

My best guess is that it is something related to Wayland…

Meanwhile the Live OS was stuck into an infinite loop, I was able to jump into an another TTY, log in and launch the command startx… And I actually finally landed into a totally working newbie-friendly environment… The problem is that the infinite loop actually keept recalling the focus, so I can’t really do much there…

Any idea about any workaround to be able to being able to proceed with the installation, keeping in mind I’m forced to stick with safe graphics mode?

Thanks in advance to anyone who could lend any help!


Also thanks to everyone who contributed to all this KDE software… I’m running it in another machine and I’m having a blast so far!

1 Like

Set your computer to boot into runlevel 3. Log in and start graphical environment with a command: startplasma-x11
Edit: not sure how this cooperates with your safe-graphics mode…

1 Like

Thanks, you saved my day!

Just in case anyone else ends up in my same situation with Neon Live in safe graphics mode stuck in an infinite loop:

On the boot selection grub:

Pick “KDE neon (safe graphics)” and press E key to edit the selection.

On the line: “linux /casper/vmlinuz boot=casper apparmor=0 quiet splash nomodeset ---” add " 3" just after “nomodeset” so it will became: “linux /casper/vmlinuz boot=casper apparmor=0 quiet splash nomodeset 3 ---”.

Then press F10 to boot.

When the login prompt appears log as “neon” and an empty password (just enter).

Then on the command line run:


At this point the Neon Live should be back on rails and finally load the desktop.

1 Like