Maliit-keyboard breaks x11 login and proton with "-bypass-wm-hint"

I have a 2-in-1 laptop and use Wayland to get niceties like autorotate. I installed maliit-keyboard from apt and managed to get that working. However, it being installed breaks games in Proton. As far as I can tell, this is because Proton uses x11. So I log in with x11 and it hangs after entering the password. Checking .xsession-errors reveals

Invalid parameter ‘-bypass-wm-hint’

Usage: /usr/bin/maliit-server [options]

Uninstalling maliit-keyboard is enough to make things work again, but I want the virtual keyboard for tablet mode.

Is there a way to configure KDE to not start maliit with “-bypass-wm-hint” to see if that helps?

1 Like

Dude! This is exactly the same problem I’m having.

Can’t login now. I mean, wayland works.

Did you find a solution to this? Cuz I need a virt keyboard too.

i reported the bug: Bug #2039721 “Can't login to X11 Session” : Bugs : maliit-keyboard package : Ubuntu

It looks like maliit’s new version is 2.3. Apt is still 2.2. So maybe they already fixed it.