Maliit Keyboard Won't Show KDE Neon

I am running KDE Neon in a Wayland Session and I cannot get Maliit keyboard to open always by pushing the input arrow in the bottom left corner. Sometimes it will open. Then when you close it again by scrolling down, it is impossible to open it again. I have seen other users in forums having similar issues. None of the listed fixes seems to work for me. I am moderately tech savvy if I know what to copy and paste…lol

Is anyone else having this issue with Maliit or have any other ideas? I could disable wayland, but I have an app in Bottles that needs the sizing scaled and it only seems to work with Wayland scaling.

It only opens on a touch event at the moment.

What is happening is that it opens on a touch event once, and then I have to slide it down to get it to close and it won’t reopen on another touch event.

This should be fixed by Try to refresh textInput active focus status (!4328) · Merge requests · Plasma / KWin · GitLab, which should probably be backported (Try to refresh textInput active focus status (!4395) · Merge requests · Plasma / KWin · GitLab)

1 Like

Sorry to be a newb. I don’t know how to install this patch

Yes, but I don’t know how to practically apply this, where to install it, etc. Sorry to be a noob, but a bit of guidance would be appreciated. Really hard to find instructions on how to apply these patches online

oh, the MR never got anywhere :frowning: It was supposed to be shipped in a bugfix release

It’ll be fixed in Plasma 6

I installed Plasma 6 Unstable, found a workaround by adding a config file, worked temporarily, now won’t come up at all. Hope the team fixes this feature soon. It does seem pretty critical.

Sorry to bother or be a nag, but do we know for certain this will be fixed in Plasma 6? Have they supposedly fixed it already? I still can’t get it to work. Comes up once. Scroll it down. Won’t come up again. When it does come up, the rest of the screen is very jittery. The thing is that if this is not likely to be fixed, I really need to switch to a new distro as I really need this functionality and for some reason, it really doesn’t seem to be a priority. I checked some of the other posts on this issue and it seems to relate to ibus running, but can’t seem to use this as a fix and system always reverts to ibus on next startup.

The specific issue with the keyboard not showing again after being dismissed is fixed in Plasma 6, yeah. Other things may not be. Integration between Plasma and Maliit is a bit shaky right now.