Maximum server connections setting for Akonadi/KMail

Recently I started having some problems with Akonadi/KMail (I have version 23.04.3). I often (about each hour) get this error dialog in KMail saying that authentication did not succeed and the server error message that is appended is the following:

Login failed, server replied: A000002 NO Too many open connections ( 50 of 50 for )

The Kolab Now tech support says that there is an Akonadi setting along the lines of “Max number of cached server connections” that I should check and lower if needed. But I can not find this setting anywhere.

Anyone knows anything about this setting or problem?

Hi Jure,

I’m not aware of any such configuration in Akonadi. The IMAP resource has hardcoded limit of 2 connections (one for downloading/uploading emails, one for push notifications). What you could try to check is whether the IMAP resource might be losing connection (due to unstable connectivity, firewall cutting the connection or what not), that could cause the connection to not be terminated properly, so the server might not detect the disconnect properly, so you quickly reach the limit of connections?

I know that e.g. GMail has a similar (even stricter) limit on the number of parallel IMAP connections to the same account and I I’m not aware of any reports from users about reaching the limit.

pprkut mentioned the same issue during Akademy and had come to the same conclusion: The IMAP resource disconnects due to a timeout, but the server still considers the connection active.