Merkuro off by one day while system is correct

Merkuro is off by one day no matter what I do. Tried uninstalls and reinstalls, reconfiguring the google connections, etc…

I loved using Kalendar for everything. It was the best. Day one Merkuro being wonky and seemingly having no means of resolving is a pretty huge bummer.

1 Like

do you have your linux clock set to local time or the default UTC?

timedatectl set-local-rtc 1 --adjust-system-clock

i used this option to have linux interpret the internal clock as local time rather than UTC and i think that’s what is causing the shift.

for me it’s only off by a day when UTC passes midnite, otherwise it’s fine.

if you wanted to unfuckit, you’d probably have to go back and unset that parameter, and for me it’s not worth it because i still boot to window on occasion so it would mess up the clocks every time without this setting.

1 Like

I cannot reproduce your issue.

Can you post the output of timedatectl and locale ?

That was my first thought too. When I still had Windows I had some issues with the normal clock too.
Do you have this issue only with merkuro or with the normal clock aswell?


               Local time: Mon 2023-09-18 11:15:12 PDT
           Universal time: Mon 2023-09-18 18:15:12 UTC
                 RTC time: Mon 2023-09-18 11:15:09
                Time zone: America/Los_Angeles (PDT, -0700)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
         This mode cannot be fully supported. It will create various problems
         with time zone changes and daylight saving time adjustments. The RTC
         time is never updated, it relies on external facilities to maintain it.
         If at all possible, use RTC in UTC by calling
         'timedatectl set-local-rtc 0'.



before i installed kalendar (merkuro now, hate that name btw) my clock only popped up a calendar when i clicked on it and i never noticed if the “today” highlight was off or not so to that part i can’t answer.

but since installation, when i click on the clock i get the calendar AND i get the events panel where i can + Add an event.

when i then click on + Add it takes me to kalendar where i can view by day and click on “today” and it will be fine up until the evening time when UTC clicks over into tomorrow, then it says “today” is one day ahead.

normally the “current time” highlight line is present in the view showing where “now” is on the day view but after midnite UTC the view shows me “today” without a current time indicator

so that tells me kalendar is getting mixed signals and not handling the discrepancy well in the GUI.

also i’m not signed into google or any other calendars, if that matters.

i’ve set a kalendar event for later this eve to watch the ball drop on kalendar and see what it does when UTC ticks over, but as of right now everything looks peachy, it knows today is monday and it knows what time it is (locally)

~ timedatectl                                                                                                                                                                              
               Local time: Mon 2023-09-18 15:48:55 EDT
           Universal time: Mon 2023-09-18 19:48:55 UTC
                 RTC time: Mon 2023-09-18 19:48:54
                Time zone: America/Detroit (EDT, -0400)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no


~ locale                                                                                                                                                                                          

So even the potential alternate time zone still says its monday the 18th.

1 Like

I just noticed. Your merkuro-calendar seems to be also off by 1 month, it says august instead of september.
Looks like 473866 – Merkuro displays wrong month/days

Still cannot reproduce even if I start with LC_ALL=en_US.UTF-8 merkuro-calendar.

Which Distro are you using?

1 Like

Im in severe pain due to some health issues and my pain brain didnt even notice the month being wrong lol.

Im using Manjaro. What I find so confusing is Kalendar worked perfectly for months until the Merkuro update. I like the idea of the Merkuro suite, I dont get emotionally attached to a name(Kalendar), its just obviously not working for me right now.

In the event that I cant get it sorted out, how would I go about reverting to back to a Kalendar build even if its older? I really dont want to start adopting Teams as my calendar app. Its bad enough that I have to use Teams for work lol.

the month displayed, was that the month that kalendar jumps to when you click on “today”?

because mine shows the correct month but i just check the day view and clicked on “now” and it took me to Tuesday and it’s only 10PM UTC, so that blows my theory about the clock thing.

i’ll also note that when i click on the clock now, the popup calendar shows the correct day, but the Event panel shows one day ahead, where this morning it did not… this behavior alternates every day and i thought is was based on UTC 0:00, but i was wrong, it kicks in even earlier than that.

if i then click away to a different day in the popup caledar and then back to today, the events panel will update with the correct day, so triggering a refresh does work to correct that part.

now when i click on + Add the kalendar window comes up showing me tomorrow, and clicking “now” has no effect… i need to then go to any other view (triggers a refresh) and it shows the correct day… going back to day view still puts me on tomorrow tho, so it’s just the day view that’s borked.

i would say that this bug is annoying but not worth jumping ship over… at least its being actively worked on, unlike the other calendar app from kontacts.

until it’s fixed you will just have to double check that when you + Add an event to your kalendar that it’s pointing to the right day (and month).

i should add that the now button on day view will keep taking me to tomorrow now that its’ after noon here… so i’m wondering now if its an AM/PM thing

anyway my kalendar is 22.04.3

Operating System: Kubuntu 22.04
KDE Plasma Version: 5.24.7
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.3
Kernel Version: 6.2.0-33-generic (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-2600 CPU @ 3.40GHz
Memory: 11.7 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 960/PCIe/SSE2

Yeah, mine is just the month view thats off.