Meta key randomly stopped working

my meta key randomly stopped working and I don’t have any idea why, it doesn’t register anywhere anymore
I have tried modifying the menu shortcut from meta+a to alt+f1, it worked… but only if I want to open the menu using alt+f1 (and also it doesn’t allow me to resize windows using meta+right click like it used to, nor using alt+f1+right click)
I have tried running ‘sudo showkey’ and the meta key actually registered there (code 240)
I have also tried plugging in another keyboard and that keyboard worked, so I am completely lost and I don’t have any idea of what to do. And I can’t just use another keyboard as I am using a labtop
If someone has any idea about what the issue could be, please share because I am starting to get desperate

I had a similar issue recently …and when I went to the bottom of it I :man_facepalming:

…although your issue may lie elsewhere, because I could not get a keypress detected either via xev (in X11) or wev (in Wayland).

unfortunately that didn’t work :confused:
fn+f2 only turns down the audio volume on my keyboard, nothing else

What I mean is that you could look at your keyboard and see if there is some
other Fn+F# key that triggers it.

On my laptop the audio buttons are on F8-F10, so it really depends from model to model.

What brand and model do you have?

As a separate idea, if the problem is software-based, did you change the keyboard layout perhaps? Perhaps to a layout that has fewer keys and therefore does not recognise Meta?

I have an asus labtop (tuf gaming f17)
the keyboard layout I use is the one specific to asus labtops so it really can’t be that (+ I’ve tried some others layouts and it does not solve the issue)

Also I’ve just noticed that when running sudo showkey, the meta key actually registers, but it shows like I instantly release it, even though I am still pressing the key down

I looked at the pictures of the laptop’s keyboard …it seems like Fn+Meta is a combination to enable/disable the Meta key.

If that is not it, I ran out of ideas, and someone else should chip in.

ok I tried changing my keyboard layout again to a random one, then back to my original, and after some time it just worked again, I think it’s either a bug or an other combination of keys to press to enable/disable the meta key
I really have no idea what fixed it, but thank you for helping me though, even if I know that something that gets fixed by itself will eventually break by itself again
also the code when pressing the meta key when running ‘sudo showkey’ went from 240 previously to 125 and doesn’t register a key release instantaneously anymore, weird

1 Like

On my machine it’s also 125.

In any case, glad to hear it works now and fingers crossed it lasts!