META+P (Screen disable) is not working like intended, any workarounds?

First off all I’m using wayland with KDE and OpenSUSE Tumbleweed.
I use a NVIDIA 2080 Super, and it works mostly fine.
The only bug I encounter is, when I press META + P to switch to disable a screen, it in fact disables for a few seconds, but then return to normal (“ON”).

Can someone open a ticket for me, because I don’t want to publish my E-Mail address in the Bug tracker, and setting up another e-mail Address can be a pain here, where I live.

And also is there a workaround for this problem, can I use a script or a custom shortcut, or both in combination to disable a screen, temporarily.
Toggling shortcut or using two shortcuts would be fine.

If a scripting and shortcut solution not implemented yet, which I suspect, please implement it :slight_smile:

To clarify, you do have multiple screens, and select “Switch to laptop” or “Switch to external screen” to disable one of them?

Looks like the same issue as Switch to laptop screen of external screen do nothing

Does it work when you disable the screen via Display Configuration system settings?